How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 35515
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Ford 150: yes I have a 2004 ford 150 no communication to

Customer Question

Hi yes I have a 2004 ford 150 no communication to the pcm
and where the miles go I have a bunch of lines
Submitted: 2 years ago.
Category: Ford
Expert:  Ron replied 2 years ago.
Hello and thank you for your question, My name is ***** ***** I will assist you today.
The expert you have requested is not on line so I will help you with this.
Does the speedometer still read the actual speed?
Customer: replied 2 years ago.
No
Customer: replied 2 years ago.
It only has lines and a letter t
Expert:  Ron replied 2 years ago.
Yes I under stand ,so your saying the odometer has dashes but does the speedometer read the speed when you drive it?
Customer: replied 2 years ago.
No nothing it will not start
Expert:  Ron replied 2 years ago.
In most cases this type of problem is caused by a failed cluster and that can also cause the loss of communication with the PCM. I would start first with making sure you have power and ground at the DLC , power is supplied from fuse 41 in the interior fuse panel. If the fuse checks okay then check power and ground at the DLC with the steps in the link below. If that checks okay then you most likely have a failed cluster. Ford released the following Special Service Message related to odometer malfunction on the 2004 F150: SOME 2004 F-150 VEHICLES BUILT BEFORE 10/02/2003 MAY EXHIBIT A BLANK ODOMETER/MESSAGE CENTER DISPLAY. THE BACK LIGHTING FOR THE DISPLAY MAY ILLUMINATE, BUT NO CHARACTERS WILL BE DISPLAYED. TO SERVICE, REPLACE THE INSTRUMENT CLUSTER.
See the DLC pin out in the link below, copy and paste it to your browser to open and view it. If power and ground check okay at the DLC then suspect a failed cluster. If the instrument cluster is replaced, Programmable Module Installation (PMI) will need to be performed, using a Ford scan tool, or equivalent
https://dl.dropboxusercontent.com/u/104923897/Data%20link%20Jun%201.pdf
Customer: replied 2 years ago.
sorry going to check truck
Expert:  Ron replied 2 years ago.
Okay , Im here if you need me.
Customer: replied 2 years ago.
Ok thanks
Expert:  Ron replied 2 years ago.
You bet.
Customer: replied 2 years ago.
Hi Ron are u still there
Expert:  Ron replied 2 years ago.
Yes Im here .
Customer: replied 2 years ago.
Ok so I have power and ground
Customer: replied 2 years ago.
With the key off I see the miles on the truck
Expert:  Ron replied 2 years ago.
Then I would suspect you have a failing ICP providing you have power and ground at the ICP.
Expert:  Ron replied 2 years ago.
I would at lease consider removing it and sending it out to be checked.
Customer: replied 2 years ago.
Where is that sensor location
Expert:  Ron replied 2 years ago.
Which sensor are you referring to?
Customer: replied 2 years ago.
The icp
Expert:  Ron replied 2 years ago.
The ICP (instrument panel cluster) is the instrument cluster assembly.
Customer: replied 2 years ago.
So the instruments cluster where can I have it check
Expert:  Ron replied 2 years ago.
Ford has there source but I know of another thats real good as well. See it in the link below,
http://www.instrumentclusters.com/
Customer: replied 2 years ago.
If I get one from a use parts I have to rePrograme the pcm
Expert:  Ron replied 2 years ago.
Yes anytime you replace it , programming is required. It will not start if this is not done.
Customer: replied 2 years ago.
Ok so the problem is the instruments cluster right
Customer: replied 2 years ago.
That y I can't communication with the pcm
Expert:  Ron replied 2 years ago.
If there is nothing wrong with your scanner and you have power and ground at the DLC then a failing cluster can keep it from commutating as well or you have something else in the system that is failing . Run the steps enclosed in the link below .
https://dl.dropboxusercontent.com/u/104923897/Scanner%20test%20Jun%202.pdf
Customer: replied 2 years ago.
I have power in the injector
Customer: replied 2 years ago.
And fuse 34 is good
Expert:  Ron replied 2 years ago.
Well then with everything you have already replaced then having the cluster checked would be the next step.
Customer: replied 2 years ago.
Ok I will check that
Expert:  Ron replied 2 years ago.
Okay.