How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Mc Your Own Question
John Mc
John Mc, Ford Technician
Category: Ford
Satisfied Customers: 6240
Experience:  19 years Ford Lincoln Mercury experience
7591113
Type Your Ford Question Here...
John Mc is online now
A new question is answered every 9 seconds

I changed the transmission fluid on my 07 ford edge and now

Customer Question

I changed the transmission fluid on my 07 ford edge and now my car wont start what could the problem be?
Submitted: 5 years ago.
Category: Ford
Expert:  John Mc replied 5 years ago.

John Mc :

Hi, I am John Mc, a Ford dealer tech. I hope I can help you quickly and accurately. One moment while I work on your problem.

John Mc :

Does it even spin over?

JACUSTOMER-ns3zfz8v- :

it does for a second then cuts immediately off

John Mc :

Did you take ANYTHING loose up top when you changed the fluid?

JACUSTOMER-ns3zfz8v- :

no

John Mc :

Battery, air filter housing, anything?

JACUSTOMER-ns3zfz8v- :

no

John Mc :

Ok when you turn the key to on does the red theft light in the dash blink rapidly?

JACUSTOMER-ns3zfz8v- :

wait i changed the air filter before i changed the transmission fluid

JACUSTOMER-ns3zfz8v- :

no

John Mc :

Ok, did you make sure you connected the mass airflow sensor back up to the air filter housing. This can cause it not to run.

JACUSTOMER-ns3zfz8v- :

yes

John Mc :

Ok, try this real quick. Disconnect the maf sensor and see if it will start. If so you may have gotten it dirty or damaged it.

JACUSTOMER-ns3zfz8v- :

ok hold on

John Mc :

ok

JACUSTOMER-ns3zfz8v- :

no

John Mc :

Ok, have you checked your fuel pump shutoff switch to see if it tripped? Some times this can happen when you lower off of jacks.

JACUSTOMER-ns3zfz8v- :

yes i checked it

John Mc :

It is back in the LR quarter panel area. You have to remove that panel in the cargo area.

JACUSTOMER-ns3zfz8v- :

i checked it when it didn't crank the first time

John Mc :

I really don't know what else to say. Your next step need to be getting it scanned to see if there are any hard fault codes. If ok next you use the scan tool to check fuel pressure. If pressure is low you could have a bad pump... Just thought of something. How low is the fuel. If it was low and you jacked up the front of the truck enough fuel could have gone to the back of the tank that it is not getting in the pump. May want to try adding a few gallons. If it has more then 1/4 tank I wouldn't think this is the problem but something to check.

JACUSTOMER-ns3zfz8v- :

I will try that my gas was on a quarter of a tank

John Mc :

If this doesn't help next step is getting is scanned.

John Mc :

If this answer has been helpful to you please help me by accepting. This is how I receive credit for helping you
today!

Also if you need further assistance for this problem after accepting feel free to ask a follow up and I'll be glad
to help.

Thanks,
John Mc

If you need me and it says I am not in chat it is ok. I get a message as soon as you respond so I can come
right back.

JACUSTOMER-ns3zfz8v- :

ok thanks

John Mc :

You're welcome.

John Mc :

...