How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Aric Your Own Question
Aric
Aric, Technician
Category: Consumer Electronics
Satisfied Customers: 44706
Experience:  15+ years in the field. Owner of AV Installation, OEM and Repair company
24739752
Type Your Consumer Electronics Question Here...
Aric is online now
A new question is answered every 9 seconds

My grace encore digital radio is giving me trouble. Presets

Customer Question

my grace encore digital radio is giving me trouble. Presets are fine but when I go to genre pick 'comedy' then go to location and specify 'uk' , it tells me it is loading ten stations then immediately reverts to location choice menu. Same thing if I specify 'classic rock' or any other genre. In every case it tells me it is loading the stations then reverts to previous menu. What is going on?
John MacDonald
Submitted: 1 year ago.
Category: Consumer Electronics
Expert:  Aric replied 1 year ago.

Hello and sorry you're having problems. How long have you owned the Grace for and when did the problem occur?

Expert:  Aric replied 1 year ago.

The first thing you will want to do, is to go into the "Settings MENU" of the machine, and "Revert to Factory Defaults".

Reset to Factory Defaults Puts all the settings back to their defaults as they were when the unit left the factory. If you perform a factory reset on your radio you will lose all your presets and your wireless network connection. Please note that your radio’s serial number will still be registered with your Grace Digital internet radio account (assuming you already registered the radio). Any premium station passwords, my stuff stations and podcast that were saved on our web site will be saved and re-associate with your radio after you power back on, log onto your network.

Once you set the unit back up again, this should clear the issue you're having. If it does not, then unplug the system from power for 5 minutes, plug it back in and Revert To Factory Settings once more.

Let me know what happens please.

Feel free to reply back if you need more help, or want to reply back with more details. It does not cost you anything more to reply back once you've rated. Please do rate me positively (at least 3 STARS) and I will continue with you until this is sorted. The positive rating ensures I am credited for my work.