How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Service Tech
Category: Consumer Electronics
Satisfied Customers: 10923
Experience:  8+ years of professional experience
13568747
Type Your Consumer Electronics Question Here...
Russell H. is online now
A new question is answered every 9 seconds

HELP!! I just got my Garmin FR70 in the mail today, I have

Customer Question

Good Evening, I am Kristin, HELP!! I just got my Garmin FR70 in the mail today, I have been trying to set it up all day.
Question 1: When I press the light on then off and press and hold it the watch says scanning for ANT, then I get a message "scale not found".... Do I need to connect the ANT to activate my foot pod?
Question 2: I am having no success at linking my foot pod to my watch. I have attached it correctly to my shoe and then I cannot get to training mode, it says "sport. general bike or run. I am a cyclist. the display does not look like the picture, my little foot pod icon does not appear.
HELP please...I have a big ride tomorrow, thanks
Submitted: 1 year ago.
Category: Consumer Electronics
Customer: replied 1 year ago.
It is now 10pm, I sent my question to you at 8:06, whats the deal?
Expert:  Russell H. replied 1 year ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

I strongly recommend you to connect the ANT first. If the foot pod is wireless / radio / WiFi, then you need the ANT to work.

I suspect you have a defective ANT; That does sometimes happen, disappointing as it is. (I recollect only one such case, but that was how it turned out.)

I think this, because you say you have followed all the instructions in the books, and gotten no result. This indicates a defective wireless link, either in the ANT or in the Garmin FR70... unless you may perhaps have A. a very noisy industrial environment around you, like a machine room or a laundry room, in which radio emissions are abundant, or B. a metal-walled environment in which signal echoes might create 'dead zones'... rare, but it can happen.

I would say, return the Garmin FR70 and ANT as defective promptly, and get either an exchange for working units, or at least a refund. (If they were bought from the same vendor or store, that would be convenient for this process.)

As for why your answer was not prompt: I suspect that many Experts here retire in the evening hours of Eastern U.S. Time for rest and dinner and sleep. I myself happened to be awake and took your case on... or it might have waited until morning (Eastern Time zone) unfortunately.