How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask ITPeter Your Own Question
ITPeter
ITPeter, Electronics Engineer
Category: Electronic Musical Instruments
Satisfied Customers: 18138
Experience:  Over 16 years' experience in installing and repairing electronics.
30970729
Type Your Electronic Musical Instruments Question Here...
ITPeter is online now
A new question is answered every 9 seconds

I have a Mark 110 Kurzweil that will not produce sound. I've

Customer Question

Good evening, I have a Mark 110 Kurzweil that will not produce sound. I've just had the amplifier replaced on the circuit board, but still no luck
JA: What's the make/model of your device? How old is it?
Customer: Kurzweil Mark 110. I don't know the age, but at least 10 years old
JA: How long has this been going on? What troubleshooting have you tried?
Customer: It's my fiancée's piano and is my understanding that it has been silent for at least 4 years. She was able to plug it into a guitar amp and produce sound which lead me to believe the small amplifier on the circuit board was at fault so I just had it replaced, performed a factory reset, but still no sound
JA: Anything else you want the Instrument Expert to know before I connect you?
Customer: No
Submitted: 1 month ago.
Category: Electronic Musical Instruments
Expert:  ITPeter replied 1 month ago.

Hi, I'm Pete. Welcome to JustAnswer! I'm reviewing your question now, and will post back with your reply ASAP.

Expert:  ITPeter replied 1 month ago.

Can you hear any audio through headphones if you connect a pair to the piano?

Customer: replied 1 month ago.
There is no headphone jack on this unit. It's a pretty high-end instrument...baby-grand piano--not an electronic keyboard.
Expert:  ITPeter replied 1 month ago.

Do MIDI Out devices receive a signal ok?

Customer: replied 1 month ago.
Not sure what that means Pete. I'm not super electronically-literate
Expert:  ITPeter replied 1 month ago.

There are MIDI connections on the Mark 110 - these allow you to connect it to other devices.

By connecting it to a MIDI device you can check if a signal is being received.

If it is outputting a signal but you are not hearing any audio through the built-in speakers then either the amplifier or the speakers is at fault.

You could try testing the voltage and resistance of the speakers as well, to see if any signal is being sent to them from the amplifier.

Customer: replied 1 month ago.
Hello Pete. I did replace the amplifier...assuming that was the culprit as I did confirm that the speakers were functioning. I can look around the piano for a MIDI connection, though I'm not sure what I'm looking for. Will it be obvious?
Expert:  ITPeter replied 1 month ago.

Yes, there should be three round MIDI connections, labelled IN OUT and THRU.

Customer: replied 1 month ago.
Ok. I'll look for them. I'm out of town now for a few days but will follow up when I've had a chance to review. Thank you
Expert:  ITPeter replied 1 month ago.

Ok, let me know how you get on when you get back.

Customer: replied 1 month ago.
Hey Pete, I'll be back tomorrow evening. I will follow up with you then. Thank you
Expert:  ITPeter replied 1 month ago.

Great, looking forward to hearing from you :)

Customer: replied 1 month ago.
Hello Pete, I'm finally getting back to the piano and I Did locate a headphone jack and MIDI connectors. I've tried connecting a guitar amp via both the headphone jack and co-ax audio cables...still no sound is being generated
Expert:  ITPeter replied 1 month ago.

If you are not getting any audio through the built-in speakers nor the other outputs, then the amplifier or its power supply is suspect.

Can you test the amplifier to ensure it is receiving power, and outputting a signal ok?

Customer: replied 1 month ago.
ok. not sure how to test the amp. I did have a new amp soldered onto the main board, but I guess I did not have it tested before hand.
Expert:  ITPeter replied 1 month ago.

Did you solder the amp yourself? Have you checked the soldering connections?

Are you sure the replacement amp was new, or was it used?

What test equipment do you have available?

Customer: replied 1 month ago.
I had an electronic repair outfit specializing in micro-soldering install the amp so I'm fairly confident in the connections, but you never know. I purchased the amp as new from eBay.
I have access to a multi-meter, but not super confident in my ability to use it properly
Expert:  ITPeter replied 1 month ago.

If unsure how to test the voltages, a local repair company can test it for you to avoid any damage.