How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Other
Category: Electric Vehicles
Satisfied Customers: 28676
Experience:  Worked on fleet of various electric vehicles, golf carts, scissor lifts and electric booms.
30244710
Type Your Electric Vehicles Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

2006 EZGo electric......in use, accelerating up a slight

Customer Question

2006 EZGo electric......in use, accelerating up a slight grade, foot on pedal, power on.......heard click and immediately no motor, cart disabled. batteries charged previous morning. Lights are on.
JA: Where exactly do you think the noise is coming from? And how long has this been going on?
Customer: Hard to say, I think under the seat. I examined all wires, all look good an clean contact points. it was an immediate loss
JA: What is the model of your '06 electric?
Customer: I know it is EZGo, don't know model. i am not at it's location now.
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: i would like to, i have not had time to do a through investigation
JA: Anything else you want the mechanic to know before I connect you?
Customer: will i need to be at the cart when i am contacted?
Submitted: 4 months ago.
Category: Electric Vehicles
Expert:  Curtis B. replied 4 months ago.

Thanks for giving me the opportunity to work with you! I will do my best to help.

Expert:  Curtis B. replied 4 months ago.

You going to have to work on it where it quit? Do you have voltmeter to test with? What is full battery pack voltage? Has to be close to 36 volts. Do you have 36 volts to each side of the solenoid? Are all cables tight, and connected, grasp each cable and give it a good tug, to be sure you don't have a corroded cable. And check cables up to the drive motor.

Customer: replied 4 months ago.
I have towed it back to our house, in garage. I am currently at work and will check the items you listed tonight. I do have voltmeter. Does it matter when i respond to you, as it may be tomorrow afternoon?
Expert:  Curtis B. replied 4 months ago.

OK, when you get to it, plug in the charger ans see if the charger comes n. If it NOT come one, you have a break in the primary circuit , cables from charger connection , through battery pack, and back to the charger port.

Customer: replied 4 months ago.
I plugged in the charger. It 'clicked' on, but the meter did not move off "0"the battery pack has 36V readingThe forward/reverse switch does not have audible signal when put into reverseHow can i check the cables, as the charger plug assembly has concealed wiring?
Expert:  Curtis B. replied 4 months ago.

What reading do yo get at he charger port on the cart? Should read same as battery pack. To check cables, just give them a good tug and see if they are tight and connection is good, if bad, it will cone apart!

Customer: replied 4 months ago.
Okay, i will check tonight.
Expert:  Curtis B. replied 4 months ago.

OK>