How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Other
Category: Electric Vehicles
Satisfied Customers: 28699
Experience:  Worked on fleet of various electric vehicles, golf carts, scissor lifts and electric booms.
30244710
Type Your Electric Vehicles Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

My batteries discharged on my 09 ezego 36 volt killing the

Customer Question

My batteries discharged on my 09 ezego 36 volt killing the charger. I recharged all of them individually and when I go to put the neg cable on after hooking them back up it has a arc . Everything is off, it does not do it if the controller loom I'd disconnected at the module or in tow mode. Could it be in the speed controller ? The relay is open between the large studs.
Submitted: 1 year ago.
Category: Electric Vehicles
Expert:  Curtis B. replied 1 year ago.

Make and model of cart? Ezgo? Connections all correct, and now you have 36 volts across the pack, before connection? Here is typical Ezgo system.

Customer: replied 1 year ago.
It is a 2009 ezego, 36v we plugged in the charger over night and the next morning all the batteries were discharged and the charger will no longer charge it has a blown fuse. I recharged all of the batteries one at a time which took almost 24 hrs. Ea. Checked the relay and is open across the large posts. The only time I don't get an arc put tinting back the ground wire is by either putting it in tow mode or by unplugging the controller wire loom at the module box or what ever it might be referred to.
Customer: replied 1 year ago.
Forgot to mention, Also getting arc with the key in off position in forward, neutral, and reverse selections.
Customer: replied 1 year ago.
36.4v at batteries. Not a spark but an arc.and all cable connections are proper, tight and correct changed nothing upon charging batteries just had then broke between the batteries and main posts.
Expert:  Curtis B. replied 1 year ago.

If you put cable on with tow switch on, and then what happens? Will cart drive, Does charger come on if attached?

Customer: replied 1 year ago.
I just reconnected the ground wire and it sparked connected it any way put the switch in run mode and it goes f/b can hear the selonoid click in am checking for voltage drain none in last 10 minutes holding @ 37.8v we bought a new, better charger for it but have not used it yet. Now there is just the tiniest little spark when I put the cable back on with the key on or off
Expert:  Curtis B. replied 1 year ago.

The resistor on the solenoid will always cause a small discharge!

Customer: replied 1 year ago.
Should we try and run it today and check it tonight to see if it arcs or drains the battery is again?
Customer: replied 1 year ago.
If so could it be the selonoid
Expert:  Curtis B. replied 1 year ago.

Could be.