How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard, Customer Service
Category: E-Readers
Satisfied Customers: 38482
Experience:  Avid repairer and trouble shooter of E-Readers
Type Your E-Readers Question Here...
Richard is online now
A new question is answered every 9 seconds

I purchased an older model w/keyboard from a private owner,

Customer Question

I purchased an older model w/keyboard from a private owner, not Amazon. I got it registered and turned on wifi, but it doesn't download my archived items. What do I need to do?
JA: What's the make and model of your tv, and has turning it on been a problem in the past?
Customer: This is a kindle not a tv.
JA: How long has this been going on? What troubleshooting have you tried?
Customer: I just received the kindle by mail. I have searched Amazon online but all they tell you to do is try all the same steps again.
JA: Anything else you want the eReader expert to know before I connect you?
Customer: I can give you the serial number, version and wifi MAC address if you need any of this. It says it has wifi and 3G capability.
Submitted: 1 year ago.
Category: E-Readers
Expert:  Richard replied 1 year ago.

Hi there and welcome

Are you getting an error message at all when it tries to download?

Please let me know

Customer: replied 1 year ago.
I tried to use the shop in kindle store and I get a message that it cannot connect at this time. Could it be that even tho it shows my internet connection it really isn't connected?
Expert:  Richard replied 1 year ago.

This is usually an issue with the Firmware, so I would first like you to do this please.

Remove the charger from the Kindle and hold the power button to off for 35 seconds.

Release, then connect the charger and try to turn on the Kindle and use it.

Let me know the results please

Thank you