How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 24343
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Io had a lift kit put on my 2015 ram 1500 about a year ago

Customer Question

io had a lift kit put on my 2015 ram 1500 about a year ago this week while driving and hitting a bump the whole back of the truck starts swaying today the engine light came on with traction light and the truck has no power snaned it have code 0344 camshaft position sensor
JA: Is the power loss consistent, or does it fluctuate?
Customer: flectuate
JA: Are you fixing your Ram 1500 yourself? What have you tried so far?
Customer: nothing yet just bought the sansor
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 6 months ago.
Category: Dodge
Expert:  sprinkles08 replied 6 months ago.

Hello and welcome to JustAnswer! I apologize for the extended wait time you experienced, I've only just come online now and would like to assist you with your question.

P0344 sets when the engine controller sees an intermittent signal from the cam sensor. This could be a wring or connection issue, possibly a cam timing issue, but is almost surely a bad cam sensor. If no visible wiring or connection issues can be seen then you're quite safe with just replacing the sensor.

My goal is to give you the best experience possible! I hope I have earned a 5 star rating! Please remember to rate my service by selecting the 5 stars at the top of the screen before you leave today. If you need more assistance, please use the reply box and let me know.

Customer: replied 5 months ago.
Ok I changed the sensor and still having the same issue the truck seams like it doesn’t want to go over 35 miles an hr and my traction and engine lights are on
Expert:  sprinkles08 replied 5 months ago.

Did you clear the fault codes?