How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roy Your Own Question
roy
roy, import/domestic specialest
Category: Dodge
Satisfied Customers: 6190
Experience:  ASE master tech for 40 years
3506196
Type Your Dodge Question Here...
roy is online now
A new question is answered every 9 seconds

Getting code P0159. Replaced exhaust manifold on passenger

This answer was rated:

Getting code P0159. Replaced exhaust manifold on passenger side as it was rusted around gasket. Replaced 02 sensor 2 bank 2. Code continues to come on after letting off accelerator at highway speeds.
JA: Is this your first time dealing with this issue? What size is your engine?
Customer: I've been dealing with this for over 2 years. Taken it to Dodge and they can't diagnose the issue. 3.7 v6
JA: What is the model of your '02 Dodge?
Customer: It's a 2011 dakota
JA: Are you fixing your Dakota yourself? What have you tried so far?
Customer: Read above....
JA: Anything else you want the mechanic to know before I connect you?
Customer: No

hello, my name is ***** ***** I will be glad to assist you. please allow me a couple of minutes to gather some basic info.

Roy

ok

has anyone checked the wiring for you???

P0159

ItemDescription

Symptom/DTCP0159

Descriptor

O2 Sensor 2/2 Slow Response

Probable Causes

  • Exhaust Leak
  • Oxygen Sensor (O2S)
  • Oxygen Sensor (O2S) Bank 2 Sensor 2 Signal Circuit
  • Oxygen Sensor (O2S) Return Downstream Circuit
Customer: replied 1 month ago.
Roy, I have checked all wiring. I know what all the possible causes are. I didn't pay to find that out. That info is on the internet. �� I've taken it to a Dodge dealership and they can't even pinpoint the problem.

the slow response is from either the signal circuit or the pcm itself not processing the information.

remember I am here and not there and do not have the luxury of checking it myself. I would find the issue if I was there.

what is the voltage of the sensor engine running???

Roy

Customer: replied 1 month ago.
I have no clue. Can I find that out by using my code reader?

no, you need a real scan tool.

Roy

Customer: replied 1 month ago.
I have a ODBII code scan/ reader tool

does it read live data??

Customer: replied 1 month ago.
it does.

ok tell me the voltage of bank 2 sensor 2 when running

Customer: replied 1 month ago.
The CEL isn't on currently, I reset the computer earlier today. Will it still show a problem if there is one?

re setting does absolutely nothing. the issue is still there. you are better off leaving the light on. there is freeze frame data that is stored when the code sets.

just tell me the reading with it running???

Roy

roy and other Dodge Specialists are ready to help you
Customer: replied 1 month ago.
Fluctuating between 0.05 and .88. All over the place.
Customer: replied 1 month ago.
Up and down
Customer: replied 1 month ago.
I replaced the 02 sensor about a year and a half ago, maybe less. Light still came on. About 3 weeks ago I replaced the passenger side exhaust manifold thinking it had a leak since it was very rusted and corroded.

got answering machine

Customer: replied 1 month ago.
The light only seems to come on after driving at highway speeds for 20-40 miles. Once you let off the gas to exit highway, light comes on.
I didn't mean to accept the phone call offer. I hit it by accident but there was no way to cancel.

you can request a refund but the site will not pay me for my efforts. is that what you want??

Customer: replied 1 month ago.
because I hit it by accident and there was no way to cancel.
Customer: replied 1 month ago.
I'm sorry but I did not mean to hit it

ok, then I am going to opt out. we or the experts expect to be paid for our efforts. we do not work for nothing. it is the only way we get paid. when refunds are given, that knocks us out.

no worries. this will be my last post to you and I have to move on to others where I get paid.

the voltage should be stable. from thos readings it looks like you have a bad cat converter causing the slow response.

Roy

Customer: replied 1 month ago.
Im very sorry Roy. It was an accident. Thanks for the info.

your welcome