How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Dodge
Satisfied Customers: 3940
Experience:  Owner at Carolina Auto Service &Sales , 20 years Experience in Foreign & Domestic vehicles
45790705
Type Your Dodge Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

We have a 2005 Durango that has been having some issues. It

Customer Question

We have a 2005 Durango that has been having some issues. It will run fine and the. All of a sudden not start. We have taken it to our mechanic who had replace the front control mod with success getting it going, but it wasn't a smooth process. He has been getting used modules but the issues has happened twice now, and wondering if a new mod is needed or if the issue lies somewhere deeper being the same thing keep happening even after changing out the module.
Submitted: 1 month ago.
Category: Dodge
Expert:  Chad Farhat replied 1 month ago.
Hey how are you
These modules are common issue ,so him getting a used one from junk yard could be bad or goes bad afterwards, but how long is it lasting
Did he check pins on connnector engine harness side , tell him to check with a flash light for any bent pins ,loose ,corroded that is making poor connection
And to answer your question most like;y the module needs to a new one , the new ones are upstaged modules that handles heat better.
Do you know if he has a Chrysler scaner specific or using basic code readerPlease let me know
Chad
Customer: replied 1 month ago.
I'm assuming it's a basic code scanner, it's a small shop.This last time it made it about a month or so and then out of no where it just wouldn't start. I had just drove about 60 miles with no issue and tried starting it about an hour after, and nothing.When he towed it back he messed around and just unplugged and plugged it back in, and it started. We picked it up a few days later and started right up, and my brother in law (engineer gear) started it up and drive it around the block and went through the wiring and all looked good.....then went to start it, and wouldn't start again.
Expert:  Chad Farhat replied 1 month ago.

I would get a new module, but if you can have it scaned with chrysler scaner, pay the $100 at dealer and get these fault to be sure and you can post them back here for me and i can be more accurate for you

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Expert:  Chad Farhat replied 1 month ago.

You are very welcome :)

Please Read Below How to Get Back in touch with Me

Please Take a Second and Click the Stars at the Top of Your Screen To Rate Me , So I May Receive my Credit , A 5 Stars Rating is Much Appreciatted

Follow Up Questions are Included in The Price of Your Question ,So Feel Free To Ask Me.

Please Keep in Mind that when you Rate Me , it Does Not End our Conversation.

You Can Always Come Back to this Conversation and Ask Me any Follow up Question you May have on this Issue

(You can Copy this Link Page & Paste it in your Browser when Ready and it will Open up our Conversation Again)

or there should be a Tab on your Screen to Add me As Your Favorite Expert

I'm Online Daily from 7 Am Till Late Eastern Time Zone

Thank You
Chad Farhat
ASE Certified Technician