How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Fix_It_Man Your Own Question
Fix_It_Man
Fix_It_Man, ASE Certified Technician
Category: Dodge
Satisfied Customers: 17475
Experience:  ASE Master Certified Technician with over 20 years experience.
1627031
Type Your Dodge Question Here...
Fix_It_Man is online now
A new question is answered every 9 seconds

No power and use lots of gas, 2005 3.3, Van carevan, New

Customer Question

No power and use lots of gas
JA: Is the power loss consistent, or does it fluctuate?
Customer: 2005 3.3
JA: What is the model of your '05 Dodge?
Customer: Van carevan
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: New plugs an wire sensors and convertor
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 2 months ago.
Category: Dodge
Expert:  Fix_It_Man replied 2 months ago.

Hello, my name is***** you tell me if the check engine light is coming on? How many miles are on it?

Customer: replied 2 months ago.
check engine is on and millage 198,000. Miles. I change Cadillac converter.O2 sensor, plug wire , plugs
Expert:  Fix_It_Man replied 2 months ago.

Thank you. Do you have a scan tool that reads sensor data?

Customer: replied 2 months ago.
No i dont, i live in alaska and iam 3hrs away frm the nearest parts store..if you cant send an answer its fine..i cant keep checking my email.
Expert:  Fix_It_Man replied 2 months ago.

It sounds like you may have a bad fuel pressure regulator or leaking fuel injectors. Without seeing some of the sensor readings and checking the fuel trim readings it will be hard to tell for sure.

Customer: replied 2 months ago.
Even when it starts the whole engine vibration..it use 5gal. Gas in 50 miles and no power even to get on car ramp
Expert:  Fix_It_Man replied 2 months ago.

You either have a sensor that is reading way off, a leaking fuel regulator or an issue with a leaking injector. Could you get a different scan tool. That would help.