How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mechanic01 Your Own Question
Mechanic01
Mechanic01, ASE Certified Technician
Category: Dodge
Satisfied Customers: 983
Experience:  Owner at Baltic investments
99232115
Type Your Dodge Question Here...
Mechanic01 is online now
A new question is answered every 9 seconds

I have codes related to the transmission and my truck wont

This answer was rated:

I have codes related to the transmission and my truck wont shift into gear. Codes:nP0700, P0731, P0732, P0733
JA: Have you checked the level of your transmission fluid? Is it bright red, or is it dirty?
Customer: It was red but smelled burnt after I limped it home
JA: What is the model/year of your Dodge?
Customer: 2004 1500 4x4 5.7 hemi
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: I've only dropped the pan and removed the sump filter and regular filter that looks like a oil filter
JA: Anything else you want the mechanic to know before I connect you?
Customer: That all thank you

Hello my name is ***** ***** I will be assisting you with all of your vehicle questions today. Give me one moment while I review your question and come back with a answer. Please be aware I do not know your skill level or abilities so I will be asking a lot of questions and in a lot of cases we will respond to each other quite a lot before we find a solution. As far as phone calls are concerned that is the system prompting you, not me, and they do cost more money, I prefer text but in some cases a phone call is required

If no debris clear codes install new filter and test drive to see what codes return

Customer: replied 2 months ago.
Unfortunately I dont have an alternative ride. This will take some time. I need to locate and pick up supplies
Customer: replied 2 months ago.
I am not familiar with dodge but I did take 2 years of motorcycle mechanic school

ohhhhh bummer, well this chat will stay open for a few weeks, let me know what you come up with ill be working all weekend,

Customer: replied 2 months ago.
Thank you. I will be in touch asap

no prob! we will figure this thing out !

Customer: replied 2 months ago.
I have new sump filter and filter. New gasket and fluid to the proper level. When I start the truck and put it in drive or reverse it take up to 4500rpm+ to move and I can hear somewhat of a squealing noise from the tranny

so it dosent move at all?

Customer: replied 2 months ago.
At high rpm and slowly

sounds like bad clutches, did you erase all the codes ?

Customer: replied 2 months ago.
I disconnected the battery for 10 minutes. Not sure if that's the correct way?

do that and hold the cables together for a min or so reconnect and see what she does, when you crank up there should be no codes

until you start shifting

Customer: replied 2 months ago.
Codes are clear
Customer: replied 2 months ago.
I started it and move it a little in foward and reverse. Has code p0700, p0731 , p0876

ok I have to call it quits for the night my brain is going to explode, can I get back with you tomorrow on this ?

Customer: replied 2 months ago.
No problem. Have a good night. Catch you tomorrow
Customer: replied 2 months ago.
P0876 is the transmission oil pressure switch. Would you recommend that I replace it before proceeding? Local auto store has 1 in stock for 85$

You can try it but I dont think its going to fix anything, the reason that code is coming up is the switch is detecting low pressure in the trans case from what I believe is some sort of failure could the solenoid pack or other issues, try these tests and see what you come up with

1. Unplug the Black/Green (C4) connector from the Powertrain Control Module (PCM).

2. Check the resistance between the Yellow/White wire at pin 21 and the Yellow/Orange wire at pin 19 in the PCM connector. It should be about 300 ohms.

3. Remove the transmission relay.

4. Jumper terminals 30 to 87 at the transmission relay and check for B+ on the Yellow/White wire at pin 21.

Customer: replied 2 months ago.
I will give it a try and let you know asap

Sounds good ill be around, my brain is working today lol

Customer: replied 2 months ago.
Lol

yesterday all I got for 10 hours straight were complicated electrical problems and the info to fix them were hidden deep down in my system and by the time you came online my head was about to bust lol, good nights sleep and some good breakfast did the trick. ill be on all day though so take your time and we can figure this out today

Customer: replied 2 months ago.
Sounds good. Hopefully today. I'm working in my driveway and it pouring rain. Supposed to be like this for a few hours. Soon as it slacks up I'll make some progress and update you.

Yeah no worries if not today, tomorrow, I guarantee the problem will still be there

Customer: replied 2 months ago.
You were right. The pressure sensor didn't work. Of the connectors I'm looking at I don't see one black with green on it.

is the connector just green?

if there is a green one thats it

Customer: replied 2 months ago.
Got no ohms on 21 to 19. When you say check for b+ at 21 I'm a little confused. + to 21/- to ground?

just 12v on the wire

Customer: replied 2 months ago.
No ohms but has b+ at 21 with relay jumped

ok everythings working ok so the next step is to replace the trans solenoid pack, when you did the filter did you do the sump filter too?

Customer: replied 2 months ago.
I did both filters. What about the 300 ohms at 21 to 19. I got o.l.

thats good, thats what you want, everything checks out, so it looks like your looking at a solenoid pack, but before you spend the money on that this pack only fixes a hand full of trans, most have internal damage and need a rebuild.

Customer: replied 2 months ago.
If I can get by for a while with a solenoid pack I'll be in good shape. No matter what it is a work truck and my boss will help me out financially. I'll discuss with him the options and let you know how it works asap.

https://www.youtube.com/watch?v=w2v7Sn5py7U

you can get it from summit for 150

heres a video on replacement,

Customer: replied 2 months ago.
Awsome! Thank you very much.

sure thing! let me know what happens

Customer: replied 2 months ago.
I got it back together. Put in in drive, Rev, 2 and 1. Got nothing. I did the resistance test between 19 and 21 on c4 of the pcm and got nothing. It's not moving foward or back at all. I will say the pan was full of small metal particals before I cleaned it and reinstalled the new solenoid pack.

I was afraid of that, from the other codes you got made it seem like there was more internal damage, looks like you need a full rebuild or replacement,

Customer: replied 2 months ago.
What about the o.l. between pin 19 and 21. I have the new solenoid pack on. Could it be a loose or broke wire? Or a bad new pack?

COuld be a bad connection or bad pack,

those connectors at the trans are known to have a ton of problems

Customer: replied 2 months ago.
Either way, I think I'm as far as I can go for now. I relly appreciate you getting me this far. I know I did what I could. Thank you!

sure thing! I wish you the best, ***** ***** to text me back if you have any more questions and also dont forget a good rating before you go

Mechanic01 and other Dodge Specialists are ready to help you
Customer: replied 2 months ago.
Thank you. You've been great!