How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 8064
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
10114124
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

I have a 2007 dodge magnum 3.5 giving me a 0700 and a 2767

This answer was rated:

hey i have a 2007 dodge magnum 3.5 giving me a 0700 and a 2767 code not sure what transmission i have.. but my symptoms are.. the car works fine in the morning but after my work shift the car runs fine for 15 minutes then it i starts to malfunction ... i have to press the gas pedal way down to get it up to 40mph then it wont down shift past that and seems to go in limp mode and the manual part of the transmission doent work. and the ac compressors seems to shut down then comes back shortly
JA: Has the clutch been slipping? Are you having any trouble shifting?
Customer: i keep it on automatic and it works for the most part but once starts to malfunction i can heard the car engine rpm's increase and it wont shift properly.. after i cut the car off then restart it its fine for a while
JA: Are you fixing your Magnum yourself? What have you tried so far?
Customer: yes DIY... i have replaced the erg valve and alternator and replace battery ober the past 2 weeks
JA: Anything else you want the mechanic to know before I connect you?
Customer: not that i can think of

Hello, let me review your request. Please stand by.

Customer: replied 3 months ago.
2D4FV47V27H624766 here is the VIN just for reference

The code p2767 is for the fauly input speed sensor 2 circuit.

Customer: replied 3 months ago.
i know i got that from another users post but why would tht cause my ac to shut down and it works fine until the evening time. then it works after i cut the car off and restart???
Customer: replied 3 months ago.
also can you tell me if i have the nag1 or the 42rle
Customer: replied 3 months ago.
from the vin

A faulty speed sensor can give you the same symptoms you are experiencing. Ther is no direct connection in between the transmission and ac but the pcm can cut the ac out to prevent additional damage when in limp mode.

The transmission info is not provided in the VIN, It is on the transmission itself for encodedin the TCM. 42rle is the most common on these vehicles/.

Customer: replied 3 months ago.
i should be written somewhere on the trans visibly from the bottom?

It is usually engraved or a tagged on the transmission bell housing.

Do you have any other questions?

Customer: replied 3 months ago.
sorry had to step away ... is there any other problem that could be causing the issue? shift solenoid, fuel filter/injector etc. i want to make sure this is the problem

The code p0700 indicates that there are codes present in th TCM. If any additional components are acting up the codes will be present in the TCM for it.

Customer: replied 3 months ago.
If it is faulty my guess is it should not work after i cut the car off then restart the car.. the does alway trigger when i experience the problem
Customer: replied 3 months ago.
The....code.... does not always trigger...

Once you cut and restart that takes it out of limp mode.

Customer: replied 3 months ago.
Hmm interesting but does it reset the faulty part?
Customer: replied 3 months ago.
Could the temparture of the part cause it to malfunction?

It will only take it out of limp mode but the codes will stay in the history. A sensor with a resistance issue could get affected by temperature.

Customer: replied 3 months ago.
Ok i have verified i hve the nag1 how do i replace the speed sensor?? The provided diagram is not my trans... thanks

Let me check.

I'm having a hard time finding location of the sensors on this model. I will opt out and let another expert assist you.

Good afternoon and welcome to JustAnswer!!

My name is ***** ***** I have worked for a Chrysler-Dodge-Jeep dealership for 19 years and I will do my best to help.

Can I get your VIN number?

Customer: replied 3 months ago.
2d4fv47v27h624766... i have purchased the conductor plate and the 6 internal sensors.. and will attempt a diy...parts shld be here next week

Thanks for the VIN!!

Per your VIN you have a Bright Silver 2007 Magnum with a 3.5L engine and a NAG1 transmission. The code you have is P2767-INPUT SPEED SENSOR 2 CIRCUIT NO SIGNAL. I have attached the test that you will need to follow to determine the issue.. If you need a Input speed sensor then you will need to replace the leadframe on the valvebody part number 52108308AC.

If you need anymore assistance feel free to shoot me a reply and don't forget to RATE 5 Stars before leaving the site so I get credit for helping you today..

Have a great day,

Brad

-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 8064
Experience: 16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
-Brad- and 7 other Dodge Specialists are ready to help you