How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1754
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

2005 dodge magum esp bas light came on after I changed the

Customer Question

2005 dodge magum esp bas light came on after I changed the rotors and prake pads front inner and outter ball joints
Submitted: 3 months ago.
Category: Dodge
Expert:  Mechanic01 replied 3 months ago.

Hello my name is ***** ***** I will be assisting you with all of your vehicle questions today. Give me one moment while I review your question and come back with a answer. Please be aware I do not know your skill level or abilities so I will be asking a lot of questions and in a lot of cases we will respond to each other quite a lot before we find a solution. As far as phone calls are concerned that is the system prompting you, not me, and they do cost more money, I prefer text but in some cases a phone call is required.

Expert:  Mechanic01 replied 3 months ago.

Did you have the codes scanned?

Customer: replied 3 months ago.
no
Expert:  Mechanic01 replied 3 months ago.

You can get a free code scan at the local parts stores and then that would give us an idea of whats going on

Customer: replied 3 months ago.
autozone said they did not scan brake problems
Customer: replied 3 months ago.
let me know what you know
Expert:  Mechanic01 replied 3 months ago.

they should do a scan, I would try a different parts store if thats the case, you may have a steering angle sensor issue or a abs sensor problem, or something else, I wont really know until you get the codes