How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1754
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

I have a 2003 intrepid that a motor was just installed in.

Customer Question

i have a 2003 intrepid that a motor was just installed in. the oil screen was clogged so he pulled the pan and cleaned it. motor sounds good except for a second at start up. it has set for a few weeks and he went to move it and the battery was dead. he put another battery on it which may have been bad but did start with a jump box. battery light stayed on then finally went off. had smell of sulfur or rotten eggs while we were jumping it. while driving from one location to another he slowed down to turn a corner and it shut off and wouldnt restart. he put a battery off of his vehicle and it still wont start and he said he smells the odor and the cables are getting hot. will turn over for a few inches then stops.he said all of the connections seemed tight. what do you suggest?
Submitted: 10 months ago.
Category: Dodge
Expert:  roy replied 10 months ago.

good evening my name is ***** ***** i will assist

the fact that the pick up was clogged is not good and may have damaged the motor. I assume this is a used engine. anyway, it sounds like the engine has locked up from lack of oil pressure when the pick up was blocked.

Roy