How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1754
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

09 caravan replaced leaking heater hose assy-no heat

Customer Question

09 caravan replaced leaking heater hose assy-no heat afterward ft l & r or rear heat.hoses are hot-checked for blockages cleaned hrt cores.reassembled still no heat. air works perfect but turn knobs to heat- front or rear-no heat. doors appear to be moving but not far enough to giv heat.air does turn off but goes to outside temp when knobs turned to heat.it is odd that all three zones are affected-is there a fuse or relay?
Submitted: 11 months ago.
Category: Dodge
Expert:  -Brad- replied 11 months ago.

Welcome to JustAnswer!!! My name is***** will be helping you with your question today...

Expert:  -Brad- replied 11 months ago.

So your plastic Y heater hose assy was leaking and you replaced it? Did you just replace the rubber lines or did you install the complete assy? Was the heater working fine before the lines started leaking? Also if both heater lines are equally hot going into the firewall then you have a blend door issue..

Talk soon,

Brad

Customer: replied 11 months ago.
the whole assembly was replaced. The heat worked fine prior to the hose assembly replacement. The hose assembly has been removed and flushed to remove the possibility of a blockage in the lines. The lines are equally hot going to the firewall. If it is a blend door issue would all zones, front and rear, left and right, be effected? I had it scanned and the doors appeared to be working on the scanner. What do we do now?
Expert:  -Brad- replied 11 months ago.

Good morning...

If both heater hoses are equally hot going into the firewall we can assume the heater core is flowing, but you could flush it with a garden hose to make sure.. It's odd that the heater was working fine until the heater hose replacement which leads me to believe we have a flow problem. The rear has it's own heater core and separate lines so it shouldn't be affected.. Now you said the front or rear isn't working? Are both lines to the rear hot and flowing coolant fine? Aldo do you have manual or zone control (ATC)? It's hard to believe that the blend door failed when the hose started leaking so again I think we have a flow issue.. Did you install the hoses back like they were from the factory?

Customer: replied 11 months ago.
All work to this point has been completed by a reputable garage and all of your suggestions have been completed before contacting you.