How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1754
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

How do we check for the pulse out of ecm pin 57 and pin 59

Customer Question

how do we check for the pulse out of ecm pin 57 and pin 59 ----2006 dodge ram 3500 5.9 cummins diesel codes are p2149 and p2146 engine starts and runs for about 2 seconds and dies if you turn the key when it dies turns over but nothing but if turn key off about 10 seconds it will run again for 2 seconds and same. have checked most everything else I think its gets pulse from ecm first 2 seconds but what should it be on pin 36-46-56-30-40-50
JA: Is the car in "Park" or "Neutral?" Do you know if your car has a "wheel lock" feature?
Customer: this is a 6 speed manul
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: truck ran good had fan wire cut issues but truck ran good so sent ecm to be fixed and they said they found no problem and we sent back ecm because truck had these issues after we put ecm in they told us it was a security issue so had a dodge tech come re program keys and same issues and we have checked all wires to and from ecm and probably anything else a shop can check fuel pressures rail pressures turning engine over filters about everything but please ask checked pulse at crank shaft sensor cam shaft sensors vistronic fan clutch wires all pulse and 5 volts were as it supposed to be and probably more but please ask me if you think of something but I think it looses the pulse after 2 seconds at ecm
JA: I'm an assistant to the Dodge Mechanic. I work with them to help customers like you.
Customer: yes I read a lot of your threads and there great
JA: Anything else you think the mechanic should know?
Customer: we are a shop and had different guys on it and I'm thinking the people that worked on ecm may not be as good as we hoped
Submitted: 11 months ago.
Category: Dodge
Expert:  bill replied 11 months ago.

do you have the full diag procedures for those codes?

they indicate injector electrical problems

Customer: replied 11 months ago.
injectors and valve cover gasket is great
Customer: replied 11 months ago.
would love to talk on phone but the last time I didn't get the problem fixed but was charged
Expert:  bill replied 11 months ago.

check this engineering document out it addresses the codes you have

talking on the phone will be of little help and i cannot send you links to documents over the phone

https://www.dropbox.com/s/rgrpbplh6kkr7h7/2149.pdf?dl=0

Customer: replied 11 months ago.
fixing to go home and can type or talk on phone later or tomorrow
Expert:  bill replied 11 months ago.

ok I DO NOT DO LIVE CALLS they are not always worth the time or expense

we can continue tomorrow

Customer: replied 11 months ago.
ok bill sounds great
Customer: replied 10 months ago.
hey bill sorry about today, but it will be Monday before I can get back to you or the truck had some honey do issues come up.
Expert:  bill replied 10 months ago.

that works fine

Customer: replied 10 months ago.
hey bill I`ll be back and forth around computer
Expert:  bill replied 10 months ago.

it's ok but please read the document i sent and let me know the results i ahve seen a few injectors short and still test ok

Customer: replied 10 months ago.
we checked each one a time and gasket about 3 weeks ago truck ran fine before we sent ecm in to be repaired and when ecm came back that's when problem started but we checked all that comes with the p2146 and p2149 codes then we sent ecm back and they said they repaired something to do with 3rd wire on fan but still same problem with it runs 2 seconds and shuts down
Expert:  bill replied 10 months ago.

i wish you would have said that in the beginning post, sounds like the ecm is defective since it started AFTER the ecm was repaired, also if the ecm was reflashed the security and vin MUST be reinsatlled or the truck will never run, you need a dealer level scanner for this

Expert:  bill replied 10 months ago.

ok i see in the original post you mentioned that my blind a$$ must have missed it, but you need to be sure the vin is in the ecm AND MATCHES the vehicle vin

sounds like the security is enabled

Customer: replied 10 months ago.
yaeh bill that's why I wanted to no about the volts or pulses on those pin #`s what they should be and how long they will be there during test so I can get another ecm. because I'm worried the ecm place might not no what there doing we tried to save customer money by getting it repaired from a sight on ebay
Customer: replied 10 months ago.
we also reflashed the keys with the dodge vin# ***** code
Customer: replied 10 months ago.
on snapon solus the only thing disabled is VTA I have no idea what the VTA is that's when we reflashed the keys to vin #
Expert:  bill replied 10 months ago.

there are no pulses all the security info is sent via communication "BUS" if the vin's do not match or there is NO vin in the ecm the security will not allow the truck to run

do you have any way to verify the vin is in the ecm AND correct

never have had luck (except bad) with rebuilt ecm's

all factory ecm's are blank and have the latest program installed at the time of install with a factory scan tool or similar programming devixce

VTA is vehicle theft alarm

Customer: replied 10 months ago.
that's what we came up with also and that cleared after redoing all keys and the volts or pulses I need are the ones on pin 36-46-56-30-40-50- on c1 on ecm so we can test and confirm when I call them that they don't need to be working on ecm`s if they don't no what there doing
Expert:  bill replied 10 months ago.

i need the vin to get the correct diagrams and so i can see what those actually do

Customer: replied 10 months ago.
ok give me a few min
Expert:  bill replied 10 months ago.

ok

Customer: replied 10 months ago.
but those pins are the ones to all the injectors seperatly and I think the common for bank 1 is pin #57 or #59 one is for bank 1 and the other is bank 2 with 3 injectors on each bank ok vin# *****
Expert:  bill replied 10 months ago.

pin 57 is for the rear bank positive feed (common) pin 59 is the positive feed (common) for the front bank (1,2,3) the other pins are negative pulses from the ecm to fire the injector, remember a computer only gives a ground the positive feed is a high side driver (electronic rela on the ecm main board)

BUT the injectors use higher than battery voltage to fire (gas engines use 12 volts) cummins uses 48 volts

do you have the wiring diagram for the injectors?

Expert:  bill replied 10 months ago.

but i have to ask again did you read the document i sent? it addresses the codes you have

and can you read the vin in the ecm it MUST match or the vehicle theft alarm will not allow the vehicle to run for more than 2 seconds

Customer: replied 10 months ago.
I have the wiring diagrahm on this truck and now I no that what I thought was groud is the positive and I will look back at that document you sent but I don't think I got all of it
Expert:  bill replied 10 months ago.

it's a very short document and was created by cummins to help us with their systems

Customer: replied 10 months ago.
I looked at it and that's why we sent ecm back they told me that they cleared the codes when they received ecm but had no issues come back after that. they told us it was a security issue and we told them we reflashed everything back in it keys and vin# ***** still same. as I am like your document if no wiring problem or valve cover gasket problem or injector problems its there problem in the ecm
Expert:  bill replied 10 months ago.

you may need a trip to a dealer to verify the vin and security info as far as i know only a WiTech(that's the dealers vehicle specific scan tool) can read all the security and vin wheras your aftermarket tool may not be able to read everything a dealer scan tool can

Customer: replied 10 months ago.
I was just wanting to confirm to them that if I checked for a volt or pulsing when turning engine over that where not getting nothing as I'm not getting a reading from ecm from those pins. and ill be back to computer in a little while ive got to go move a machine
Customer: replied 10 months ago.
ok bill ill get back in a little while
Expert:  bill replied 10 months ago.

if the truck runs for 2 seconds then shuts down that's a classic security issue, the system is designed to run for a few seconds then shut down if it does not recieve the correct security info OR if the vin is missing or incorect

Customer: replied 10 months ago.
bill there are no security issues and i no it seems like a security issue and vin # is correct in ecm
Expert:  bill replied 10 months ago.

correct me if i am wrong but you said your solus said the VTA was disabled if so that means the security has been activated

if you send the vin i can look up the options and verify it either DOES or DOESN'T have VTA

you also said this all started after an ecm was replaced this indicates a failed ecm or the security DID NOT get installed properly

are there any codes setting in ANY module you can read

your solus should be able to read most modules on this truck if it's up to date

Customer: replied 10 months ago.
hey bill---yes the vta vehicle theft alarm was disabled but we had refashed and vin # put in had solus cheked and we had the tipm totally intergrated power module come up on checking wires to the fuses and battery ground checked and passed that nothing comes up on our solus or otc scanners but I do want to let you no this truck does not have the original vistronic fan clutch witch was at one point electric 6 wire plug but 5 wires and I followed the wiring diagrahm to ecm and everything it goes to the truck ran before the ecm had work done on it. now I should get a code if that were keeping it from cranking like not getting pulse from fan ecm that its not turning.im just throwing that out there I no some dodges get I think p2509 not sure but we have had that before on a customer with fan clutch issues from wires getting cut but this truck has a fordhub with dodge fan clutch and fan not electric anymore maybe old ecm was bypassed or programmed for it I don't no all I no was it was running when it came in---that's why I just needed to no what the pulse for scope or volts the pin on ecm should read on the injector pins 36-46-56-30-40-50======57-59
Customer: replied 10 months ago.
thank for your help on this bill I appreciate the effort and will be glad to pay and rate on this and will be using in the future as when we get stumped I had always went to forums and read just answer and it is sometimes the answer and always good info as theres many forums on vehicles were not formiliar with and its great that these people take the time to post and video this stuff
Customer: replied 10 months ago.
will get check back in a bit have a duramax going in limp mode and a bobcat that want move
Expert:  bill replied 10 months ago.

still sounds like the ECM or the WCM ( security module) is shutting the truck down, there are procedures that the factory scan tool can do such as redownloading all the vehicle info and forcing the ecm to relearn all the security data from the WCM even a locksmith can't do that as of yet

not gonna ask for a rating until this thing is running

Customer: replied 10 months ago.
ok bill I'm back but its late here 11;30 just checking in before going bed. a friend of mine that works at the Chrysler jeep that reflashed the key with ecm I don't remember if it was a witech he had but ill get him to check with his scanner but it might be Friday or Saturday before I can get back to you. thank you bill chat later
Expert:  bill replied 10 months ago.

if he has a witech have him run the ecm replaced function on the WCM

and maybe even the vehicle restore function

good luck

Related Dodge Questions