How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1754
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

We have a 2005 dodge ram 1500 4.7L truck. The compressor

Customer Question

We have a 2005 dodge ram 1500 4.7L truck. The compressor will not engage. Freon is properly charged. We have replaced the a/c pressure switch. When we jump the relay from number 30 to 87 the compressor kicks on and system gets cold. The relay signal is missing coming from the PCM. we are checking continuity now. we are skilled mechanics but don't work on these trucks and this issue very often. Any ideas?
Submitted: 1 year ago.
Category: Dodge
Expert:  Wayne Crawford replied 1 year ago.

Hello. My name is ***** ***** I will be helping you today.

How do you know its not related to the charge?

Customer: replied 1 year ago.
Gauges show its properly charged and when we jump it it blows ice cold
Expert:  Wayne Crawford replied 1 year ago.

What are your pressures when you jump it?

Customer: replied 1 year ago.
210 high and 50 low
Expert:  Wayne Crawford replied 1 year ago.

And you think 50 is ok on the low side?

Expert:  Wayne Crawford replied 1 year ago.

210 is ok on the high side if its 70 degrees outside.

Customer: replied 1 year ago.
Well what should low side be then? That's why I am paying you you are the expert..
Expert:  Wayne Crawford replied 1 year ago.

Whats the ambient temperature?

Customer: replied 1 year ago.
90
Expert:  Wayne Crawford replied 1 year ago.

OK. Well the low side is ok at 90.

The high side is not.

Its undercharged.

Get that high side up to 260 and let me know if it still has an issue.

Customer: replied 1 year ago.
there is no leak in the system and my mechanic swears that ain't the issue . He believes its electrical . There is continuity between pin 11 and 86 on relay which is between compressor and computer . It's not getting a signal from computer he believes . He has checked all exposed for shorts and nothing found.
Expert:  Wayne Crawford replied 1 year ago.

Its not supposed to get a signal from the computer when the charge is low.

Customer: replied 1 year ago.
It was the AC heater cluster on dash ..
Expert:  Wayne Crawford replied 1 year ago.

That may be. That doesnt excuse it being undercharged. You should always start with the basics. When it hits 100 it may not work because its undercharged.