How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Dodge Technician
Category: Dodge
Satisfied Customers: 26442
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Dodge Question Here...
Amedee is online now
A new question is answered every 9 seconds

Ok I have a 2006 Dodge Ram 1500 with the 4.7 and auto trans.

Customer Question

Ok I have a 2006 Dodge Ram 1500 with the 4.7 and auto trans. I'm getting a brake light abs light and no speedo all happen same time. The codes show p0501, u1417 and u 1418. I have checked brake fluid, changed dif speed sensor and trans rear sensor. I also removed and blew out the abs connector no moisture or corrosion. I checked all the fuses. I unplugged battery for about 6 mins and it cleared all codes. The U codes came back. Speedo still not working. As a side note I noticed on the forums ac and heat not working in some post my ac and heat appear fine.
Submitted: 1 year ago.
Category: Dodge
Expert:  Amedee replied 1 year ago.

Hello and welcome! My name is ***** ***** I can assist you with your question. Have you checked the speedo reading in the CAB?

Expert:  Amedee replied 1 year ago.

Chances are the module is not communicating because it is bad or missing an input. Your first step would be to check to see if the ABS control module is able to communicate with your scanner and then check to see if it is seeing vehicle speed as the vehicle is being driven.

Expert:  Amedee replied 1 year ago.

Chances are there is going to be an issue with the CAB module or ABS module. If it is communicating but not reading the inputs correctly, then we need to check the wires from all of the speed senors to ensure there are no shorts/open or breaks in the wiring.

Expert:  Amedee replied 1 year ago.

If there is no communication with the ABS/CAB module, you may want to start by checking the fuses.. as it needs to be powered up in order to work.. and yes, this is fused.

Expert:  Amedee replied 1 year ago.

Fuse 13 and 18 power up the ABS module

Expert:  Amedee replied 1 year ago.

Also, fuse 28