How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jon Your Own Question
Jon
Jon, ASE Certified Technician
Category: Dodge
Satisfied Customers: 310
Experience:  Master Chrysler/Jeep/Dodge Tech
62301042
Type Your Dodge Question Here...
Jon is online now
A new question is answered every 9 seconds

I have a 2004 dodge dakota 6cyl 2wd and my two brake lights

Customer Question

I have a 2004 dodge dakota 6cyl 2wd and my two brake lights are not working. Turn signals work and the top brake light on cab works. Fuse 4 inside the truck keeps burning out. What could be wrong?
Submitted: 2 years ago.
Category: Dodge
Expert:  Jon replied 2 years ago.

Hi, does this vehicle have a trailer harness?

Customer: replied 2 years ago.
Expert:  Jon replied 2 years ago.

Ok, fuse 4 in the junction block inside the truck feeds the parking lamp relay. Can you unplug C352 and tell me if the fuse still blows out? I attached a picture where c352 is.

Customer: replied 2 years ago.
Does it look like this?
Expert:  Jon replied 2 years ago.

Looks right, it's a black 14 pin connector

C352 - BLACK (CHASSIS SIDE)

CAVCIRCUIT

1L1 18VT/BK

2L62 16BR/RD

3L63 16DG/RD

4Y203 16RD/WT

5L207 18YL/BK

6B40 14LB

7-

8L7 18BK/YL

9B113 20RD/VT

10B114 20WT/VT

11K4 18BK/LB

12K226 18DB/WT

13A61 16DG/BK

14Z1 16BK

Customer: replied 2 years ago.
I unplugged it and fuse still blew. Now I have engine light on
Customer: replied 2 years ago.
I do have a slight burnt smell in the truck coming from under the steering wheel area
Expert:  Jon replied 2 years ago.

Ok, I'm not in front of a computer right now but that eliminates something in the rear. I'd pull both turn signal lamps for now, it's a small torx to remove them and start looking for shorts and I'll get back to you shortly.

Expert:  Jon replied 2 years ago.

Front turn signal lamps I mean

Expert:  Jon replied 2 years ago.

Here is a wiring diagram from fuse 4 in the junction block. If that fuse blew out, it looks like it has to be something in the front that's blowing it.

Customer: replied 2 years ago.
Ok I'll look in to that
Customer: replied 2 years ago.
It started happening after I put a boat in the water
Expert:  Jon replied 2 years ago.

Well it doesn't look like its an issue in the back considering c352 is unplugged and the fuse still blows...

Expert:  Jon replied 2 years ago.

Well it doesn't look like its an issue in the back considering c352 is unplugged and the fuse still blows...

Customer: replied 2 years ago.
Actually I tried it again today. I unplugged it and turn on the lights and left it on for a while it hasn't burned the fuse yet.
Expert:  Jon replied 2 years ago.

Ok, if its not blowing with C352 unplugged, here's the rest of that circuit:

Expert:  Jon replied 2 years ago.
Expert:  Jon replied 2 years ago.

There has to be something shorted on the black/yellow wire rearward of c352.

Customer: replied 2 years ago.
Ok I'll look to see what I can find
Customer: replied 2 years ago.
Does the short effect the brake lights as well?
Expert:  Jon replied 2 years ago.

No, if the brake lights don't work either, that's another issue with another circuit not related to fuse 4 in the junction block.

Customer: replied 2 years ago.
Oh ok. The brake light on cab works but the two in back don't work. Turn signals work as well
Expert:  Jon replied 2 years ago.

The brake/turn are on a separate circuit than the parking lights.

Customer: replied 2 years ago.
Well I found this
Expert:  Jon replied 2 years ago.

Bad combo flasher, definitely need a new one. That should fix your brake lights but that has nothing to do with the parking lamp fuse. There's probably a short still somewhere rearward of c352 that might have melted that flasher and is popping the fuse 4.

Customer: replied 2 years ago.
Yea I'm going to get a new one. I'll keep looking for the other issue with fuse 4
Expert:  Jon replied 2 years ago.

Ok sounds good.

Expert:  Jon replied 2 years ago.

How did you make out?

Customer: replied 2 years ago.
I think I got it. Been working so far. I was missing the left turn signal plugs so I put the plugs on and it hasn't burned yet.
Expert:  Jon replied 2 years ago.

Ok, sounds good. Let me know if you need any more help and please rate the service I gave you. I only get paid if you leave a positive rating.

Customer: replied 2 years ago.
The blower for the ac and heater just stopped working. Is there a relay for it or fuse?
Expert:  Jon replied 2 years ago.

Here's the diagrams for the blower motor.