How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JacobTD Your Own Question
JacobTD
JacobTD, Car Enthusiast
Category: Dodge
Satisfied Customers: 1070
Experience:  Ase Certified
19108227
Type Your Dodge Question Here...
JacobTD is online now
A new question is answered every 9 seconds

Dodge Ram 3500: I just bought a 2007 Ram 3500 6.7l cummins

Customer Question

I just bought a 2007 Ram 3500 6.7l cummins and the day after purchase the check engine light came on and the codes were P2563, p0037, p0131. The car lot told me it would be fine to bring it in on Monday. Later that day I was driving down the road and it just shut down and would not re start but it will crank. Now I'm getting c2202, c2206, u0100 & u0141. The other strange thing is that now I have no shift indicator lights in the cluster. I checked the data and the scanner is recognizing when the shifter is moved between all positions P R N D. Cleaned battery terminals and load tested batteries and all good. Checked grounds and appear to be good.
Submitted: 2 years ago.
Category: Dodge
Expert:  JacobTD replied 2 years ago.
I think I can help you out with this problem. First i need you to have all codes cleared. Are you online
Customer: replied 2 years ago.
Ok. I can go clear the codes in a few minutes. I have tried to clear them a few times and as soon as I try to turn it over they come back.
Expert:  JacobTD replied 2 years ago.
Ya they may comeback. I need the codes that do come back and the order they come. Are u able to actually scan and erase codes in the tcm also?
Customer: replied 2 years ago.
Yes. The TCM didn't show any codes. im using a friends scanner which doesn't display all codes in order. You have to open all of the modules to see what codes are there. Mine are in the order as follows:
In the TIPM module the only code is u0100
In the ABS module the codes are listed in this order: c2201 c2206 u0100 u0141. These are the only actve codes I get.
Expert:  JacobTD replied 2 years ago.
You have a comunication problem between your networked computers. I would first check all computer plugs.. fuses and relays.
Expert:  JacobTD replied 2 years ago.
I think it will be in ecm or abs u will find the problem
Customer: replied 2 years ago.
Can you help we out with where everything is located?
Expert:  JacobTD replied 2 years ago.
I can just give me a min
Expert:  JacobTD replied 2 years ago.
Is your 8th vin digit a or c?
Customer: replied 2 years ago.
A
Customer: replied 2 years ago.
ECM plugs all look good
Customer: replied 2 years ago.
Not sure where the ABS module is
Customer: replied 2 years ago.
Are you still there?
Expert:  JacobTD replied 2 years ago.
Additional information requested
Customer: replied 2 years ago.
I checked the ECU an ABS module connections. All good. Still no start
Customer: replied 2 years ago.
Please forward my original question to another expert.