How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Construction and Road Equipment
Satisfied Customers: 1231
Experience:  Technican turned service manager with multiple lines of equipment and rental units.
30244710
Type Your Construction and Road Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 130 that starts and runs 15 to 90 seconds then

Customer Question

I have a 130 that starts and runs 15 to 90 seconds then shuts off. The fuel filter has been changed. The small fuel pump under the radiator runs.
JA: What is the complete model and serial number of your machine?
Customer: Tl130
JA: Are you fixing this yourself? What have you tried so far?
Customer: 21306141
JA: Anything else you want the construction mechanic to know before I connect you?
Customer: Changed fuel filter and checked the fuel line from the injector pump to the tank
Submitted: 5 months ago.
Category: Construction and Road Equipment
Expert:  Curtis B. replied 5 months ago.

Hello! Let's see if we can work together and come to a satisfactory conclusion!

Expert:  Curtis B. replied 5 months ago.

Have you checked the fuel shutoff solenoid. It has to hold the injection pump in the run position. Turn key on and check it for battery voltage, it should have voltage on one wire to the common wire. The second wire is only powered when starter is engaged It pus solenoid into run position, and the first wire, which is always powered ,has to hold it open. Sounds like it pulls in, but the solenoid does not hold, so engine shuts off.