How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Construction and Road Equipment
Satisfied Customers: 5319
Experience:  17+ yrs. shop and field experience with all major brands of heavy equipment and trucks - 1995 WyoTech graduate.
65405794
Type Your Construction and Road Equipment Question Here...
Dan is online now
A new question is answered every 9 seconds

Starting problem with 2007 gehl ctl70 got it stuck in mud up

Customer Question

starting problem with 2007 gehl ctl70 got it stuck in mud up to top of tracks after letting it sit for a day to get winch to pull it out i can get it to run for 1-2 seconds then dies lots of white smoke tried bypass of water sensor and grounding it no help changed fuel pump and filter no help the oil light and water light blink could there be a oil sensor that could have gone bad
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  Dan replied 1 year ago.

Hi my name is***** will be glad to help. Sounds like the mud and water could have damaged the sensor or harness or the cooling system is plugged causing an overheat condition. Check the coolant level and for damaged sensor or harness. Let me know

Customer: replied 1 year ago.
The water and mud only got 1-2 inches in engine compartment no mud in radiator. Coolant level is fine oil level is fine sensor is fine. Bypassed sensor by grounding it. Fuel transfer pump got disconnected after plugging back in it looked like not pumping much do I replaced the pump. Manuel say to turn key on for 20 seconds to bleed air out I also used primer pump on injection pump to bleed air. It will start but only run 1-2 seconds them die.
Expert:  Dan replied 1 year ago.

Thanks for the update. If there are no fuel restrictions or leaks in the suction lines between the tank and pump then the transfer pump is likely the culprit. Try runnint a separate hose from a separate fuel container to confirm. See if it will run from a separate fuel source bypassing your existing suction lines. If so then it is a problem between the tank and pump. If not you are looking at a transfer pump or injection pump issue. Let me know

Customer: replied 1 year ago.
I did replace transfer pump, unscrewed fuel filter and is moving lots of fuel to it, it still has same problem will start for 1-2 seconds then dies
Expert:  Dan replied 1 year ago.

Does it die instantly like you turned off the keyswitch or act as if it is running out of fuel?

Customer: replied 1 year ago.
Dies instantly
Customer: replied 1 year ago.
Send me your email I can send video of it
Expert:  Dan replied 1 year ago.

We are not allowed to share e mail outside the site without authorization through an additional services link which is an additional cost but check the coolant level and sensor and harness as low coolant will shut these machines down. Try bypassing the sensor by grounding it to see if it still stalls if the coolant level is not below the sensor. Let me know

Expert:  Dan replied 1 year ago.

It is common on these machines.

Customer: replied 1 year ago.
I did that originally said that in 1st and second post
Expert:  Dan replied 1 year ago.

Are you getting any warning indicators coming on when this happens?

Customer: replied 1 year ago.
Oil pressure/ water temp and battery
Customer: replied 1 year ago.
The water and oil same light
Expert:  Dan replied 1 year ago.

Thanks for the update.... I see you are also getting white smoke which is a possible sign of coolant burning in the combustion chamber.... Look for white ash deposits from the exhaust manifold and exhaust connections. Also look for signs of coolant in the engine oil.

Expert:  Dan replied 1 year ago.

If found the engine could have overheated possibly when it was stuck and you may have a possible head gasket issue

Customer: replied 1 year ago.
I have google searched this problem and have done research on this problem and have done everything hoping for some new info. Motor never got hot, and no water in oil
Customer: replied 1 year ago.
Gray ish to black ish smoke
Customer: replied 1 year ago.
How hard is it to remove air from lines or injector pump it will run for a 1-2 seconds some times up to 5-6 them dies that's when smoke is more black Ish on short runs its gray ish lot of diesel smell
Expert:  Dan replied 1 year ago.

Click on this link and see pages 34-39 for the fuel system breakdown and let me know if this is the same fuel system on your machine. http://www.hawkinsequipment.com/gehl-parts-manuals/Engines/Compact-Track-Loader/CTL70-Compact-Track-Loader-Isuzu-4JG1-TPA-Engine-Parts-Manual-917063B.pdf

If so, Remove the turbo inlet and check the impellar that there is no damage and it spins freely without any drag and does not contact the housing. A faulty turbo will cause black smoke and stalling under a load. To prime your fuel system crack open the bleeder screw or fuel line exiting the housing and pump the hand primer until there is straight fuel and close the bleeder. Continue pumping until resistance is felt . Then crack the injector lines loose while cranking over the engine until you get fuel spray and tighten the lines. Try to start the engine and repeat as necessary. If the fuel from the injection lines only trickles instead of spraying out under higher pressure with the fuel shutoff confirmed good( fuel on position) then your injection pum is faulty in need of overhaul. Let me know

Customer: replied 1 year ago.
ok ill give a try it will be a couple days bad weather and work will update in a couple days
Expert:  Dan replied 1 year ago.

Sounds good. Pleasure to help

Customer: replied 1 year ago.
Checked turbo looks perfect and spins freely, loosed all injector lines by injectors getting lots of spray while cranking engine any other suggestions
Expert:  Dan replied 1 year ago.

Thanks for the update. Does the engine try to run and will it fire off of silicone spray or ether?

Customer: replied 1 year ago.
Runs 1-2 seconds them dies as previously noted have not tried silicon spray I heard ether is bad
Expert:  Dan replied 1 year ago.

silicone spray is better since it has some lubrication but a small few spurts of starting fluid enough to know if it tries to start will be all you need. Some will use too much and it can bind the engine causing broken rings, etc.

Expert:  Dan replied 1 year ago.

This will tell us whether or not it is a fuel issue or possibly something mechanical. Let me know

Customer: replied 1 year ago.
I figured out myself it was the fuel shut off selinoid

Related Construction and Road Equipment Questions