Networking

Ask Computer Networking Questions and Get Answers ASAP

Ask a Computer Expert,
Get an Answer ASAP!

Networking

I asked questions before about monitoring network traffic

Customer Question
at home. I now have...

I asked questions before about monitoring network traffic

at home. I now have the system laid out like this: cable modem feeds into Linksys#1 wireless router, not going to use wireless on it though. Linksys#1 feeds into cisco catalyst 2960C. Other devices plug into cisco catalyst 2960C including an Asus wireless router. Everything seems to have internet access now. I don't know how to login the cisco to set up the "span session" or whatever it takes to capture network traffic.

I have another pc plugged into the cisco that will monitor traffic. That pc also has wifi built in and is connected wireless so hopefully I can remote into it to check traffic.

Submitted: 2 years ago.Category: Networking
Show More
Show Less
Ask Your Own Networking Question
Answered in 15 hours by:
10/19/2015
Network Technician: Drew, Network Specialist replied 2 years ago
Drew
Drew, Network Specialist
Category: Networking
Satisfied Customers: 137
Experience: Using 30+ years of experience to help you get it working.
Verified

Hi. My name is ***** ***** I can help you set up a span session on your switch. Once set up, whatever you plug into the span session port should be able to see all of your traffic that passes through your 2960C switch which, from what you describe, should be everything. Internet, wired, and wireless.

The basics are:

This example shows how to set up SPAN session 1 for monitoring source port traffic to a destination port. First, any existing SPAN configuration for session 1 is deleted, and then bidirectional traffic is mirrored from source Gigabit Ethernet port 1 to destination Gigabit Ethernet port 2, retaining the encapsulation method.

Switch(config)# no monitor session 1

Switch(config)# monitor session 1 source interface gigabitethernet1/0/1

Switch(config)# monitor session 1 destination interface gigabitethernet1/0/2 encapsulation replicate

Switch(config)# end

This example shows how to remove port 1 as a SPAN source for SPAN session 1:

Switch(config)# no monitor session 1 source interface gigabitethernet1/0/1

Switch(config)# end

Complete information is found in the Cisco documentation here:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/15-0_2_se/configuration/guide/scg2960/swspan.html

Please note if you are not running version 15 code on your switch, the commands might be a little different. Thus if they don't work, please let me know which version of code you are running and I'll try and dig up the docs for your specific version.

Please let me know if you have questions and how it goes.

Cheers,

Drew

Ask Your Own Networking Question
Customer reply replied 2 years ago

Ok, but I don't know how to log in the switch or get to those settings. Since I have 3 switches now, I have no idea what the ip addresses are for the switches. I assume I log in the cisco by typing the ip in the address bar and I can configure it that way?

Network Technician: Drew, Network Specialist replied 2 years ago

Well that's a tough one. The switches only have IP addresses if someone created switch interfaces and configured IP addresses. Then you also have to configure the switches for access either via telnet or ssh.

So short of that, you can access your switches via their console port and the blue, Cisco serial cable. If you know how to do that AND know the enable password (if configured), then you should be able to access the CLI.

Ask Your Own Networking Question
Customer reply replied 2 years ago
Which port should I plug the PCR in that I want to use for the capturing? I will start there I guess.
Network Technician: Drew, Network Specialist replied 2 years ago

Which ever one you configure as the span port. You can use any one you want.

Ask Your Own Networking Question
Network Technician: Drew, Network Specialist replied 2 years ago

Just checking in to see if you were able to create your span port. Do you have any further questions?

Cheers,

Drew

Ask Your Own Networking Question
Customer reply replied 2 years ago

I just got to the point where I could connect to it. I am going to try to get it working this weekend. I defaulted it a couple of times but it will not pass internet through it to my wifi router. I bypass it and get internet but put it back in and no internet. I'm still pretty lost on configuration. I'm a robot programmer by trade for 25+ years so I know the language, just too many options that I don't know what they are. I was going to focus on getting internet through it before I try to get advanced with it.

Network Technician: Drew, Network Specialist replied 2 years ago

By "defaulted it" do you mean reset the switch to factory default settings? If that's what you did, when you connect devices to your Catalyst switch, do you get link lights on the switch? The reason I ask is that I think by default, the switch ports are shut down and you have to enable them.

Ask Your Own Networking Question
Customer reply replied 2 years ago

yes, factory default. I did see in the configuration where to assign ports to a certain function. I had a router behind it and I could see the devices through the switch but no internet. Hopefully I will get it working this weekend.

Network Technician: Drew, Network Specialist replied 2 years ago

OK, thanks. I have to be the last one to reply to a thread or the system keeps telling me I have customers waiting.

Let me know how it goes this weekend and I'll attempt to answer any questions you have.

Ask Your Own Networking Question
Customer reply replied 2 years ago

Ok, I know a little more about it now but not much. I slightly know how to navigate in putty. I have a friend that will remote in to set up the span if needed but the problem is that I can't do the basic config to add the switch in line. I have internet now but if I add the switch between modem and router, internet goes away. Of course I rebooted everything but no luck.

Customer reply replied 2 years ago

I will only use 3 ports if I can't figure out how to make it dhcp. One from modem, one to router, one to sniffing pc. I would love to use the other ports for other pcs but a friend said only use the 3 ports.

Network Technician: Drew, Network Specialist replied 2 years ago

Have you been able to get into "enabled" mode? That's the privileged mode on the switch. To enter it, simply type "enable" at the command prompt and enter the password ***** required.

Once there, please give me the output of "show run". It will be a bunch of text and will show me your complete switch configuration. I don't use putty but there should be a way to capture the output as a log file. Then you can save it to your PC and attach it to this chat.

I'll look that over and see if I can give you the exact commands you need.

Cheers,

Drew

Ask Your Own Networking Question
Customer reply replied 2 years ago

Switch#show run
Building configuration...

Current configuration : 791 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500

Network Technician: Drew, Network Specialist replied 2 years ago

There should be a lot more. For example, I should see all of the ports listed and their configurations. That's the part in which I'm most interested. Can you capture it, put it in a notepad file with "word wrap" off (it's in "format"), and then attach it using the paperclip icon just above this chat box?

Ask Your Own Networking Question
Customer reply replied 2 years ago

I turned on logging, mapped the file to the desktop, chose all session output, but don't know how to get it to the document. I just copied and pasted from putty.

Network Technician: Drew, Network Specialist replied 2 years ago

You should be able to click the paperclip and then choose the file.

But pasting here works too. However there should be more. Did you keep hitting the spacebar when the "more" prompt was at the bottom of the screen? You need to do that to get all of it. Looks like you just got the first screen.

You should just be able to keep hitting spacebar until the regular prompt returns. Then close your session or scroll back up and copy all of that here.

I'm going to be away for the next 12 hours or so (evening here in the Pacific Time Zone). I will look at this tomorrow. Or if you don't want to wait, I can opt out and open this up to other experts.

Ask Your Own Networking Question
Customer reply replied 2 years ago

I could get you a file but putty isn't logging or even creating a file. I'm just ready to give up on it anyway.

Customer reply replied 2 years ago

Switch#show run
Building configuration...

Current configuration : 791 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip http server
ip http secure-server
ip sla enable reaction-alerts
!
line con 0
line vty 5 15
!
end

Network Technician: Drew, Network Specialist replied 2 years ago

See this part:

interface Vlan1
no ip address
shutdown

That is where the problem is I think. Try this:

config t

interface Vlan 1

no shutdown

exit

See if that makes your switch work and let me know how it goes.

Cheers,

Drew

Ask Your Own Networking Question
Network Technician: Drew, Network Specialist replied 2 years ago

I'm curious if you were able to try my suggestion above and if that got your switch working for Internet access?

Cheers,

Drew

Ask Your Own Networking Question
Ask Drew Your Own Question
Drew
Drew
Drew, Network Specialist
Category: Networking
Satisfied Customers: 137
137 Satisfied Customers
Experience: Using 30+ years of experience to help you get it working.

Drew is online now

A new question is answered every 9 seconds

How JustAnswer works:

  • Ask an ExpertExperts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional AnswerVia email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction GuaranteeRate the answer you receive.

JustAnswer in the News:

Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.

What Customers are Saying:

I am very happy with my very fast response. Eric is very knowledgeable in the subject area. Thank you!

RPAustin, TX

My Expert answered my question promptly and he resolved the issue totally. This is a great service. I am so glad I found it I will definitely use the service again if needed.

One Happy CustomerNew York

Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help.

Mary C.Freshfield, Liverpool, UK

This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!!

AlexLos Angeles, CA

Thank you for all your help. It is nice to know that this service is here for people like myself, who need answers fast and are not sure who to consult.

GPHesperia, CA

I couldn't be more satisfied! This is the site I will always come to when I need a second opinion.

JustinKernersville, NC

Just let me say that this encounter has been entirely professional and most helpful. I liked that I could ask additional questions and get answered in a very short turn around.

EstherWoodstock, NY

< Previous | Next >

Meet the Experts:

Claws224

Claws224

IEEE Network Engineer

1,256 satisfied customers

IEEE, Microsoft

Kevin

Kevin

LAN/WAN Specialist

1,165 satisfied customers

Certified MCSA and MCP Network Administrator with over 20 years of PC experience.

Byron

Byron

PC Support Tech

640 satisfied customers

CCNA, A+, MCSE 11 years at a large law firm.

Eric K.

Eric K.

Network Administrator

510 satisfied customers

13 years of desktop, server and network support experience

Mr. Clark

Mr. Clark

Network Engineer

510 satisfied customers

Computer Business Owner / Former DoD Network Specialist

Chris L.

Chris L.

Support Specialist

447 satisfied customers

Certified Networking expert with over 10 years experience.

A. Stevens

A. Stevens

Network Administrator

428 satisfied customers

10+ years of Desktop, Laptop, and Server troubleshooting and support.

< Previous | Next >

Related Networking Questions
I need my external ip address. I need to enter it into my
I need my external ip address. I need to enter it into my cameras DVR … read more
Patrick Evans
Patrick Evans
Network Engineer
MS
10 satisfied customers
My wireless router is no longer pass word protected model
my wireless router is no longer pass word protected model RT-N66R … read more
Bryan
Bryan
IT Consultant
8,751 satisfied customers
Setting up my asus wireless router. RT-AC1200. I've got it
I've got it plugged in I'm connected to the internet through my modem … read more
Richard
Richard
IT Manager
IT Manager, Consultant
3,281 satisfied customers
I just replaced my wireless router. Now my HP8620 will not
I just replaced my wireless router. Now my HP8620 will not print wirelessly to/from my laptop. It will print from our desktop. … read more
Viet - Computer Tech
Viet - Computer Tech
Computer Technican
Bachelor\u0027s Degree
953 satisfied customers
I am trying to activate my Belkin 692 N150 wireless router
I am trying to activate my Belkin 692 N150 wireless router to WIFI for my Chromecast 0074 streaming device, but having a very hard time using QR scanner app to bring up the necessary page to input the… read more
Russell H.
Russell H.
computer technology consultant
Vocational, Technical or Trade Scho
781 satisfied customers
Can't remembered my IP address, password. Vizio,smart
Can't remembered my IP address, password JA: Just to clarify, what device or product are you trying to access? Customer: Vizio,smart tv-D32 JA: How long have you had your TV-D32? Customer: Just got fo… read more
Isaac Franklin
Isaac Franklin
Associate of Science in Social Sciences
976 satisfied customers
What is the ip address to access my Linksys router? Can't
what is the ip address to access my Linksys router? … read more
Jason Jones
Jason Jones
AAS Information Technology
6,320 satisfied customers
Panasonic no longer recognizes my wireless router, xfinity,
Panasonic recognizes router up till about 2 months ago. It some times recognizes but can not connect… read more
arsufi2002
arsufi2002
Bachelor's Degree
322 satisfied customers
I have to unplug my Netgear wireless router at least twice a
I have to unplug my Netgear wireless router at least twice a day to reset to make it work again WNR2000 I upgraded the firmware yesterday but still having the same problem … read more
Thomas
Thomas
IT Manager
Associate Degree
983 satisfied customers
Our company is running out of the 254 ip addresses available
Our company is running out of the 254 ip addresses available on the subnet we use. We are adding more hardware and would like to keep all devices accessible from any other pc without having to change … read more
Cody
Cody
Computer Science
1,716 satisfied customers
I need to change the password for wireless router. I don't
I need to change the password ***** wireless router … read more
Ashik
Ashik
Master\u0027s Degree
5,097 satisfied customers
Authentication required for wireless router, I cannot
Authentication required for wireless router, I cannot remember the username/password. … read more
Jason Jones
Jason Jones
AAS Information Technology
6,320 satisfied customers
How to configure a ip address a router on a stick. Four
four workstation attached to a switch that is attached to 2900 Cisco router … read more
Jason Jones
Jason Jones
AAS Information Technology
6,320 satisfied customers
I have change the IP address, I have changed the subnet and
I have change the IP address, I have changed the subnet and still can't get a connection to my vp 540 printer … read more
Kris R
Kris R
IT Manager
Computing
2,654 satisfied customers
My acer laptop lost the IP address and cannot get internet,
My acer laptop lost the IP address and cannot get internet … read more
Dan
Dan
IT/Broadcast Engineer
Bachelor\u0027s Degree
508 satisfied customers
My workstations are not getting an ip address from my
My workstations are not getting an ip address from my windows 2008 server which provided DHCP.My network administrator is not available and I need my users up with local ip addresses.Help please.I can… read more
R Hefner
R Hefner
Solution Engineer
Masters of Science
74 satisfied customers
I Have a support task to change IP address to manual IP
Hi I Have a support task to change IP address to manual IP address for a HP Laserjet 1536dnf MFP ,from my laptop( different IP address).How can I change the printers IP address to a static IP address … read more
Richard
Richard
IT Manager
IT Manager, Consultant
3,281 satisfied customers
Is there a way to set up an ip address outside the US, that
is there a way to set up an ip address outside the US, that will show as a USA IP address for transactions online… read more
GeekGal
GeekGal
IT Director
Bachelors Degree
448 satisfied customers
Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Show MoreShow Less

Ask Your Question

x