How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, Mechanic
Category: Chrysler
Satisfied Customers: 16033
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chrysler Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

Instrument panel isnt coming on. When i hold down the

Customer Question

Instrument panel isnt coming on. When i hold down the odometer trip it lights up and gauges move. After they turn back off
JA: Just to clarify, what are the exact lights you're talking about?
Customer: Instrument cluster
JA: What is the model/year of your Chrysler?
Customer: 2001 town and country
JA: Are you fixing your Town and Country yourself? What have you tried so far?
Customer: Yes i am. And nothing so far. Just checked fuses
JA: Anything else you want the mechanic to know before I connect you?
Customer: Wipers radio interior lights will not work either
Submitted: 2 months ago.
Category: Chrysler
Expert:  Tim's Auto Repair replied 2 months ago.

Hi, My name is ***** ***** for the delay.
I will do my best to assist you.

Expert:  Tim's Auto Repair replied 2 months ago.

you have a common problem that happens to these town and country vans,

i would think your problem here is the cluster itself.these are known to go bad.

you can get a good deal on a used cluster at your local salvage yard or from www.ebay.com

Expert:  Tim's Auto Repair replied 2 months ago.

installing a good cluster should fix your problem

Expert:  Tim's Auto Repair replied 2 months ago.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feedback ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help.

Customer: replied 2 months ago.
this would cause the wipers radio and interior lights not to work??
Expert:  Tim's Auto Repair replied 2 months ago.

i see

first, lets try something simple,,

Remove both battery cables from the battery, turn on the ignition, touch and hold both the - and the + cables together for 5 seconds, turn off the ignition, then re-install them back to the battery

let me know if this fixed the problem