How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 22689
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

03 Chrysler T&C van 3.8 no door locks,no instrument cluster

Customer Question

03 Chrysler T&C van 3.8 no door locks,no instrument cluster wont start cranks over no wipers replaced body control module ,ignition switch electrical part,IPM module check all current and grounds And still the same and no comunition any module but PCM no sliding doors no lift gate too,
JA: Have you checked the engine's fuel supply? And the spark plugs -- are they all working?
Customer: electrial
JA: What is the model of your '03 Chrysler?
Customer: Town& Country
JA: Are you fixing your Country yourself? What have you tried so far?
Customer: replaced body control module,I,P,M module ignition
JA: Anything else you want the mechanic to know before I connect you?
Customer: replaced ignition switch checked all power and grounds too system
Submitted: 2 months ago.
Category: Chrysler
Expert:  sprinkles08 replied 2 months ago.

Hello and welcome to JustAnswer!

You could have several things going on and it will require some electrical testing to determine what is going on. I suspect you may be missing a power feed to the BCM due to a wiring problem.

Were the BCM power and ground feeds tested?

Expert:  sprinkles08 replied 2 months ago.

Your question was on the open list but there is no reply from you here. If you replied it did not post to the page.

Customer: replied 2 months ago.
If you read my question I put that in it I put a new ingition switch in it all the curent and grounds are good. The only thing I see is the ignition switch sense wire has continuity but I don't know if current suppose too be threr?The ignition switch sense return has continuity do it suppose have current on it?
Expert:  sprinkles08 replied 2 months ago.

Were the BCM power and ground feeds tested?

Customer: replied 2 months ago.
before and after you texted me back all. were good
Expert:  sprinkles08 replied 2 months ago.

Is the bus down but the scan tool is communicating with the PCM over SCI?

Customer: replied 2 months ago.
Expert:  sprinkles08 replied 2 months ago.

You're going to need to determine if the bus is shorted to power or ground and then start by disconnecting each module one at a time to see when the short goes away. If all modules are unplugged and the short is still present then the issue is in the wiring harness.

Customer: replied 2 months ago.
When I take the negative cable the door locks work one time than stops
Expert:  sprinkles08 replied 2 months ago.

That may or may not be related to the other issues, diagnose the rest of the problems first. If the problem is still present then it may be high current draw in an actuator but you're going to need to see what fault codes are setting in the BCM.

Customer: replied 2 months ago.
the ignition switch sense wire and return wire doesnt have anything to do with it from the ignition to BCM
Expert:  sprinkles08 replied 2 months ago.

Have anything to do with what?

Customer: replied 2 months ago.
What's going on with the BCM the run from the ignition switch to the BCM
Expert:  sprinkles08 replied 2 months ago.

What was the result of the bus diagnostics? You said that modules were awake but communication over PCI wasn't possible.