How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 22979
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 96 breeze. All of the dashboard indicator lights

Customer Question

I have a 96 breeze. All of the dashboard indicator lights come off and on. They finally stoped working. Now the the car is shifting funny and Will not go into drive. Although it will run in a higher gear.
JA: Have you checked the fuses? The dashboard bulbs?
Customer: I am a electrician by trade. Being an intermittent problem I have been looking for poor connections are a bad control board. I just found out that the problem could be causing transmission failures
JA: Are you fixing your Breeze yourself? What have you tried so far?
Customer: Checked all the fuses for poor connections. Checked the transmission fluid. I think there must be a dash control board involved.
JA: Anything else you want the mechanic to know before I connect you?
Customer: That's all I can give at this point.
Submitted: 8 months ago.
Category: Chrysler
Customer: replied 8 months ago.
I went back to the car and ran the engine in till the dashboard lights began to intermittently move again. I then tested the car to see if it would shift properly. The car shifts fine as long as the dashboard signals work.
Expert:  sprinkles08 replied 8 months ago.

Hello and welcome to JustAnswer!

If warning lights are coming on and the trans stops shifting at that time then odds are you have a bus communication problem. The modules all communicate over a wired network and if communication stops then all warning lights will come on. It's also possible that you're losing power or ground to multiple modules at once.

Do you know what fault codes are setting in the trans controller?

Customer: replied 8 months ago.
No warning lights are coming on. No faults are showing on scanner. All the instruments on the cluster go off and on. Must be a weak connection. Somewhere the connection is involving the transmission.
Customer: replied 8 months ago.
I was thinking about removing the instruments panel and investigate The wiring harness. Is their wiring in the engine compartment that might be loose. Maybe a connecter
Expert:  sprinkles08 replied 8 months ago.

If the trans wasn't shifting then there would be fault codes set. Please describe exactly what is happening with the transmission, as well as exactly what you see at the instrument cluster.

Customer: replied 8 months ago.
The car was having problems going in drive. I finally was able to engage in drive. Although once I got it going at a higher speed it wouldn't, shift to the next gear. No instruments were working. On the dash. There's air bag light stays on all the time. alstoped working. Don,t know if that's related. The tachometer speedometer and mileage go off and on. Maybe the p.c.m. is going out
I'm
Customer: replied 8 months ago.
Don't understand why no fault codes are showing up. Probably the computer cannot see a harness problem. Are maybe it's the computer itself. The ac controls all went out. I checked all fuses and relays. It was a computer problem. I had to jump it all out. Pretty messy but got it working. I had to by pass the whole blower control.
Customer: replied 8 months ago.
Happy new year !
Expert:  sprinkles08 replied 8 months ago.

Fault codes are setting without a doubt. What are you using to try to read them?

Customer: replied 8 months ago.
I am low on transmission I have e o.b. scanner. Also key switch system. I will go over again. The indicator lights are probably the only problem. Low on fluid. Will have to find leak..
Expert:  sprinkles08 replied 8 months ago.

The reason warning lights come on is because fault codes set so there is an issue of some sort with what you're trying to read them with. If the trans is going into limp in it's also because codes are setting in the TCM.

Customer: replied 8 months ago.
The trans. Is shifting fine was fluid. The warning light is not coming on. It's on the same circuitry with the dash. It does work intermittently when the dash indicator s come on. Does the signals that go to the dash go straight to the computer? Isn't their a connected behind the a.c. controller?
Expert:  sprinkles08 replied 8 months ago.

Warning lights come on when the respective module sees a failure and sets a fault code, then a message is sent or a hardwired signal to the instrument cluster to turn the appropriate warning light on. If there are warning lights coming on with the engine running it's because fault codes are setting.

Customer: replied 8 months ago.
We are not understanding each other. What I meant was the check light operation is not working because of the instruments. They seem to be all on the same system.
Expert:  sprinkles08 replied 8 months ago.

Do you mean that the instrument cluster isn't working at all?

Customer: replied 8 months ago.
There are no failures. I'm going to try to trace the cable down for the instruments. The book is telling me there is a connector for it behind the a.c. control. All the gauges come of and on sometimes separately. There has to be a bad connection some where. I have no module failure. The car runs perfect.
Expert:  sprinkles08 replied 8 months ago.

Are you saying that the instrument cluster stops functioning entirely?

Customer: replied 8 months ago.
The whole cluster goes off and on. Also the air bag light will stay on. Also when this is happening I can't get the check light system to work with the key or my scanner. After a period of time everything starts working again. This is all happening while I'm driving. The car is running fine. That's why I think it's an intermittent connection problem.
Expert:  sprinkles08 replied 8 months ago.

The airbag light is staying on because fault codes are set in the airbag module.

If the instrument cluster is going completely dead it's either due to a loss of power or ground or internal failure, most likely internal failure. It's powers and grounds need to be tested at the time it doesn't work.

Customer: replied 8 months ago.
That sounds reasonable. The Haynes manual is showing how to pull out the instruments cluster. Maybe it's the connected. Is there any other points I could go to check the ground connection on the harness?
Expert:  sprinkles08 replied 8 months ago.

You need to check the power and ground feeds at the cluster connector while the cluster isn't working. If ok then the problem is internal.