How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 1668
Experience:  Auto Technician
94707146
Type Your Chrysler Question Here...
Dan is online now
A new question is answered every 9 seconds

I have a 2004 Chrysler 300m that will go into Limp home mode

Customer Question

I have a 2004 Chrysler 300m that will go into Limp home mode at times. when operating temp. and coming to stop it will drop hard into first. I shut car off and turn back on it clears the problem but will happen again. Have taken to 4 shops and they have no problems??? but I pick up car and on way home it does it. ???? The past two shops said I was low on fluid. with in one week I was down tow and half quarts. NO LEAKS???
JA: How old are the hoses? And what driving conditions do you most often encounter?
Customer: when coming off a highway to a stop but than also going 30 mph to a stop. I would say hoses are original.
JA: Are you fixing your 300M yourself? What have you tried so far?
Customer: I have taken to 4 shops with no luck in them finding a problem. they fill trans with fluid and no problem. but in a week time one shop put in 1 quart and than next shop put in a quart and half. But no leaks???
JA: Anything else you want the mechanic to know before I connect you?
Customer: no that is it
Submitted: 9 months ago.
Category: Chrysler
Expert:  Dan replied 9 months ago.

Hello my name is***** am an ASE Master Technician and I am glad to help you with your question.

Expert:  Dan replied 9 months ago.

A common problem on this is the input turbine speed and output speed sensors on the trans. I have seen this problem before. The sensors are cheap may be a good idea to try replacing both of them at the same time.

Expert:  Dan replied 9 months ago.

Please reply to this if you need more help and we can continue this conversation at no extra charge. This does not have to be my only answer. If you are satisfied with my service, please rate at the top of the screen. Rating does not close out your question. Remember, sometimes it is difficult to completely diagnose your vehicle without being there, but I will try to give you the best answer I can. Hoping to be giving you 5 star service.

Thanks

Customer: replied 9 months ago.
Already done that and still have the problem. The last shop said that year had problems with the solenoids. Could that be my problem?
Expert:  Dan replied 9 months ago.

You need a scan too to see if there are any codes stored in the transmission, if it goes into limp mode then there should be codes stored.