How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 522
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

He. I finally was able to get to take the batt cables off. I

Customer Question

He dan. I finally was able to get to take the batt cables off. I left them off for about 20 min and it cleared the codes. I started the car and let it run a few min and shut it off. It idled fine and i had no engine light. I done the key thing and i got a p0517 code back. If im correct isnt that the code for my broke sensor? Could that be causing my other codes and giving me the rough idle. I ordered a new sensor today but it wont be in till thur.
Submitted: 1 year ago.
Category: Chrysler
Expert:  Dan replied 1 year ago.

Hello my name is***** am an ASE Master Technician and I am glad to help you out with your question.

Expert:  Dan replied 1 year ago.

I would start with replacing that battery temp sensor.