How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask john -aka eauto Your Own Question
john -aka eauto
john -aka eauto, The Car Guy
Category: Chrysler
Satisfied Customers: 16040
Experience:  15 years as a auto tech ASE certified
6149662
Type Your Chrysler Question Here...
john -aka eauto is online now
A new question is answered every 9 seconds

Chrysler 300 C: I have a 2013 300c 5.7 that is pinging and

Customer Question

I have a 2013 300c 5.7 that is pinging and feels flat at times when accelerating. I have no check engine light. The MAP sensor was changed and it still pings.
Submitted: 1 year ago.
Category: Chrysler
Expert:  john -aka eauto replied 1 year ago.
what octane fuel are you running?
Expert:  john -aka eauto replied 1 year ago.
Max Trailer Weight 12,000 lbs. towing capacity Maximum GCWR 22,000 lbs. GCWRso 12,000 lbs is your answer
Expert:  john -aka eauto replied 1 year ago.
oops that was not 4 you what octane 87?
Customer: replied 1 year ago.
it pings with both 89 & 93 octane!
Customer: replied 1 year ago.
Sorry 91
Expert:  john -aka eauto replied 1 year ago.
how are the plugs?
Customer: replied 1 year ago.
In my initial statement I said the dealer did a tune up. New plugs all 16 of them less that 500 miles ago.
Expert:  john -aka eauto replied 1 year ago.
http://www.hotrod.com/how-to/engine/116-0406-cylinder-leakdown-tester/
Expert:  john -aka eauto replied 1 year ago.
this web site keeps crossing posts not sure whats going on... does it ping only under load ?
Customer: replied 1 year ago.
The car has less than 50k miles on it and doesn't burn any oil. I think thats a bit extreme.
Expert:  john -aka eauto replied 1 year ago.
does it ping only under load?
Customer: replied 1 year ago.
Yes and when at operating temperature.
Expert:  john -aka eauto replied 1 year ago.
has the dealer performed a carbon cleaning of the motor? how long has it been pinging?
Customer: replied 1 year ago.
I run fuel injector cleaner thru it from time to time. The dealer says there is nothing wrong with the car. I guess if it isn't showing them so kind of code they don't know what to do or where to look. I noticed the pinging just before i brought it to the dealer for the tune up. The tune up didn't fix anything. The strange thing is the car feels like it has more power when I run the AC. Thats why I changed the MAP sensor. I read that when the AC is running a signal is sent to the MAP to change some perimeter. So I thought is was worth a $25 try on a new MAP. Could the IAT sensor be the problem? This is very frustrating.
Expert:  john -aka eauto replied 1 year ago.
usually its egr,mas air flow or a knock sensor issue or dirty fuel injectors or a carbon issue... I think the iat is built into the mass air flow on this
Customer: replied 1 year ago.
The car doesn't use a MAF. Chrysler uses mostly MAP sensors. I'll try more fuel injector cleaner. I tend to think it is a sensor because at times there is a loss of power at times so something is retarding the timing. If you think of anything specific or talk to anyone who has seen this issue let me know.
Expert:  john -aka eauto replied 1 year ago.
iat can cause pinging also...can you run a batch of non ethanol 93 and see if it helps....ethanol content is generally more then advertised at the pumps...and is terrible for fuel systems
Customer: replied 1 year ago.
I'll change the IAT next. 93 octane is hard to find in phoenix and without ethanol !!! I doubt it.
Expert:  john -aka eauto replied 1 year ago.
ahhh in ny its at every gas station,, that stinks
Customer: replied 1 year ago.
Anyway the car should adjust for differences in octane and not allow pre ignition.
Expert:  john -aka eauto replied 1 year ago.
it should I agree ..im thinking its more of a carbon issue
Customer: replied 1 year ago.
Today on my way to work while going up a SLIGHT incline ( I go this way everyday) the car would not accelerate. I was pushing the gas pedal down and there was NO linear acceleration. The car didn't start to accelerate until the transmission kicked down.
Expert:  john -aka eauto replied 1 year ago.
really wonder if its a fuel issue? have you checked fuel pressure
Customer: replied 1 year ago.
I thought of that. I just have to find a mechanic that actually practices the profession and doesn't just look for computer codes.
Expert:  john -aka eauto replied 1 year ago.
not many true techs left...

Related Chrysler Questions