How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 22996
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2006 chrysler 300 3.5 my brake light came on ABS

Customer Question

I have a 2006 chrysler 300 3.5 my brake light came on ABS light and traction, I got a u0120 and a u1120, the lights go off when I hold the brake pedal dowm in park.
Submitted: 1 year ago.
Category: Chrysler
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

U1120 sets in the powertrain control module when it isn't receiving a wheel distance message from the ABS module, U0120 doesn't show to be a valid code.

You may have a wheel speed sensor issue or the ABS module itself may be going down.

Can you double check the U0120?

Do you have a code reader or scan tool that will communicate with the ABS module so you can see if any codes are set there?

Customer: replied 1 year ago.
U0121
Expert:  sprinkles08 replied 1 year ago.

U0121 sets when there is no communication with the ABS module, the ABS module going down is why the wheel distance code is setting.

The problem is either the module itself, a communication bus issue involving just the ABS module, or a lost power or ground to it.

Are there any other items that don't work or other lights that come on when the ABS lights come on?

Customer: replied 1 year ago.
Customer: replied 1 year ago.
It started with the speedometer going crazy
Expert:  sprinkles08 replied 1 year ago.

That's because the ABS module is going down. I assume the speedometer is the only other issue?

Customer: replied 1 year ago.
The Trans also went into limp mode
Customer: replied 1 year ago.
I should replace the abs module
Customer: replied 1 year ago.
Or should I test all the wheel sensors
Expert:  sprinkles08 replied 1 year ago.

The problem is the module, a loss of power or ground or communication bus. At the time the warning lights are on the module's power and ground feeds should be load tested as well as checking bus voltages at the ABS module connector. If ok then the module can be condemned.

Customer: replied 1 year ago.
Ok thanks
Expert:  sprinkles08 replied 1 year ago.

You're welcome!