How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 22985
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2006 300 c and the battery was dead because I left

Customer Question

Customer: ***** *****. I have a 2006 300 c and the battery was dead because I left the key on. I jumped it but the controls on the steering wheel do mot work. Also the ABS,TCS,EPS and Airbag lights are on and the horn does not work. I looked at the fuses but all seemed OK. Could it be a relay? Thanks in advance.
JA: Thanks. Can you give me any more details about your issue?
Customer: this is all new. car was fine until I jumped it this morning.
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $16) to post your type of question to Chrysler Experts (you only pay if satisfied). There are a couple customers ahead of you. We can help you for less if you're not in a rush. Are you willing to wait a bit?
Customer: sure
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Chrysler
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

With this combination of symptoms I suspect the steering column module is down. All of the items you either have warning lights on for or are not working rely on the steering column module in some way. The module may have been damaged or there may just be a blown fuse. You checked fuses in both boxes?