How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 522
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Chrysler Town and Country: the hose on my van burst and lost

Customer Question

the hose on my van burst and lost all the oil out of the compressor I don't know how much to put back in the compressor
Submitted: 2 years ago.
Category: Chrysler
Expert:  George H. replied 2 years ago.
Hello I will help you with your question, Front and rear air or just front? Was anything but the hose replaced?
Customer: replied 2 years ago.
a hose burst on my 2003 Chrysler Town and Country and lost all the oil from the compressor how much oil do I need to put in the new compressor?
Customer: replied 2 years ago.
how long will it be before you call me?
Customer: replied 2 years ago.
How long will it be before you answer my question?
Expert:  George H. replied 2 years ago.
I am sorry I cannot speak on the phone, If you will tell me if this has front and rear air or just front and if you think all the oil is out of the system or just some of it I can help you with how much needs to go back in. Thank you
Customer: replied 2 years ago.
All I want to know is how much oil to put in the new compressor?
Expert:  George H. replied 2 years ago.
To give you an accurate amount I need information. Was anything except the hose replaced? Is the system dry or do you think some oil is left? If you want this to work properly I need to know what was done to repair this. Thank you