How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Chevy
Satisfied Customers: 24582
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Chevy Question Here...
Dan is online now
A new question is answered every 9 seconds

It died while driving, didn't hear fuEl pump so replaced it.

Customer Question

It died while driving, didn't hear fuEl pump so replaced it. Was not the problem. Tested fuel pump relay it's good jumpered the fuel pump it works. I have no power to switched side of fuel pump relay and no spark.
JA: Is the power loss consistent, or does it fluctuate?
Customer: It won't start
JA: What is the model/year of your Chevy?
Customer: 1999 gmc yukon
JA: Are you fixing your Yukon yourself? What have you tried so far?
Customer: I thought ecu so pulled one off a 99 surburban it tried to run just not smooth put the original ecu back on it ran a couple days aND diedvagain
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 1 month ago.
Category: Chevy
Expert:  Dan replied 1 month ago.

Hello, my name is ***** ***** I'm here to help get your problem solved.

Expert:  Dan replied 1 month ago.

Does the check engine light come on for bulb check when first turning key to on position? Is vehicle starting now?

Customer: replied 1 month ago.
I do have heck engine lgh on also security and tach doesn't move while cranking
Customer: replied 1 month ago.
No it will not start there is no power on the switched side of the fuel pump relay
Customer: replied 1 month ago.
no spark
Expert:  Dan replied 1 month ago.

CHeck to see if pink wire going to ignition module has power with key in start position, if not check to see if 20 amp ECM1 fuse is blown. If fuse is good but no voltage then replace the ignition switch. Let me know how it goes or if you have more questions, thanks.

Customer: replied 1 month ago.
I have checked all fuses, it seems as if my ecu is not getting power. Could it be a ground somewhere if so where. And just so ya know yit had a sow radiator leak and the coolant was spraying from top of radit or in driver side covering ecu and things around it.
Expert:  Dan replied 1 month ago.

Did you check to see if pink wire going to ignition module has power?