How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15201
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Stalls at speed and cuts off while driving. No check engine

Customer Question

Stalls at speed and cuts off while driving.
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: No check engine light. While driving.
JA: What is the model/year of your Chevy?
Customer: 97 Chevy Suburban 5.7 engine.
JA: Are you fixing your Suburban yourself? What have you tried so far?
Customer: Changed Ignition Control Module, checked Mass Airflow Sensor,
JA: Anything else you want the mechanic to know before I connect you?
Customer: Exhaust is corroded to the Catalytic converter.
Submitted: 2 months ago.
Category: Chevy
Expert:  TECHPRO49 replied 2 months ago.

even without a check engine light on is there any codes that dont show up?

Customer: replied 2 months ago.
Misfire and Mass Airflow are the codes that kept populating.
Expert:  TECHPRO49 replied 2 months ago.

do you have the numbered codes for that?

Customer: replied 2 months ago.
I can get them Monday. I'll post them then.
Expert:  TECHPRO49 replied 2 months ago.

Ok sounds good ill be around!

Customer: replied 2 months ago.
These are the codes just pulled, p102,p 0151,300
Expert:  TECHPRO49 replied 2 months ago.

When you checked the MAF what did you do?

Customer: replied 2 months ago.
Drove the car for miles with sensor disconnected to see if it affected performance. There was no change in performance.
Expert:  TECHPRO49 replied 2 months ago.

Ok I would pull it clean it with MAF spray and reconnect also monitor it on the scanner while messing with the connectors to see if there is any change, the wiring on that has issues sometimes