How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HDGENE Your Own Question
HDGENE
HDGENE, ASE Master Tech
Category: Chevy
Satisfied Customers: 5715
Experience:  25 years Auto experience, Ford, GM, Chrysler, Asian & European
285738
Type Your Chevy Question Here...
HDGENE is online now
A new question is answered every 9 seconds

My 4.3 vortex Chevrolet s10 LS ideals good but sputters and

Customer Question

My 4.3 vortex Chevrolet s10 LS ideals good but sputters and looses horsepower going down the road don't know what to do
JA: What year is your S10?
Customer: 2003
JA: Are you fixing your S10 yourself? What have you tried so far?
Customer: Yes tried fuel filter and distrib and rotor
JA: Has the vehicle turned into a gas hog? And how does it start -- same as usual?
Customer: Yes gas hog and a little off with starting
JA: Anything else you want the mechanic to know before I connect you?
Customer: No I don't think so
Submitted: 2 months ago.
Category: Chevy
Expert:  HDGENE replied 2 months ago.

Hello, and thank you for using Just Answer! My name is***** me a few moments to review your question and Ill do my best to assist you.

Expert:  HDGENE replied 2 months ago.

Hello, is the check engine light on and any trouble codes stored?Does it loose power at a higher rpm but ok if easy on the throttle? How many miles are on the truck? Was the fuel filter plugged up?

Customer: replied 2 months ago.
Don't know any codes yes check engine light is on been on and when I checked it before this happened it had code for Redmond misfire yes and then when I slow down it wants to cut off
Customer: replied 2 months ago.
No filter was clear 192k
Expert:  HDGENE replied 2 months ago.

Ok A random misfire can be caused by a crankshaft position sensor or a loss of fuel pressure under a load. I would have the truck re checked for diagnostic trouble codes and see if there is a crankshaft position sensor code along with the misfire codes and test the fuel pressure if needed if there are no codes other than a P0300 random misfire. If fuel pressure is weak when it happens then it can be a weak fuel pump.

Expert:  HDGENE replied 2 months ago.

Also egr valves are common faults on these 4.3 engines as well but it will set a code for the egr system if there is a malfunction

Customer: replied 2 months ago.
Changed that sensor and all of the other sensors when I try to start it now it smells like its fluxing out
Expert:  HDGENE replied 2 months ago.

What do you mean it smells like its fluxing? What else did you change?

Customer: replied 2 months ago.
I meant to say flooding out
Expert:  HDGENE replied 2 months ago.

Ok you need to run the scan on it again to see what else is going on to verify if any other codes are set since you have done some repairs to it.