How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask K. Wiggins Your Own Question
K. Wiggins
K. Wiggins, ASE Certified Technician
Category: Chevy
Satisfied Customers: 2991
Experience:  ASE Certified Technician, Associates Degree in Automotive Technology, 15+ years in the trade
68360881
Type Your Chevy Question Here...
K. Wiggins is online now
A new question is answered every 9 seconds

I have a unmolested 1969 Chevelle 350 Engine. I drove it

Customer Question

I have a unmolested 1969 Chevelle 350 Engine. I drove it into the garage a few days ago and tried to start it again yesterday, but had no electrical power, period. No ignition, no lights, no nothing. The battery is fully charged. I cleaned the batt. terminals, the ground connection to the block, tried the gear shift lever in all positions to see if the neutral switch was out of location, but nothing worked. Any ideas? Jim G
Submitted: 2 months ago.
Category: Chevy
Expert:  K. Wiggins replied 2 months ago.

hi Jim, check the connections at the horn relay. This is where the fusible links also are that feeds power to the fuse box/ignition switch. I'll post the wiring diagrams below.

If my answer has helped you please help me by rating or accepting. Rating/accepting does not cost you extra, it just ensures I am credited for my time and effort. As always any follow up questions concerning this issue are always free even after rating/accepting. Thanks!