How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JOHN aka Eauto Your Own Question
JOHN aka Eauto
JOHN aka Eauto, The Car Guy
Category: Chevy
Satisfied Customers: 16298
Experience:  ase tech
6149662
Type Your Chevy Question Here...
JOHN aka Eauto is online now
A new question is answered every 9 seconds

Our 04 6.6 lly is overheating while towing...just replaced

Customer Question

Our 04 6.6 lly is overheating while towing...just replaced the radiator, two thermostats and cluch fan. Trunk now runs at 210 empty..is that in a normal range.
JA: Have you checked the coolant? Have you checked for a leak in the cooling system?
Customer: No leaks
JA: What is the model of your '04 Chevy?
Customer: Kodiak
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: At a repair shop...os 210 to high empty?
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 3 months ago.
Category: Chevy
Expert:  JOHN aka Eauto replied 3 months ago.

Hi . Thank you for asking your question on JustAnswer. so its running at 210?

is it pushing out coolant or anything?

Customer: replied 3 months ago.
No, just had a new radiator installed and 2 new thermostats and a new fan cluch. On a 94 degree day running with no load it now runs at 198. Tomorrow we will hook up our 45 ft toy hauler and see how she does. That seems high for no load, what is your thought?
Customer: replied 3 months ago.
On flat land it is now running at 240...we will head back to the repair shop..
Hoping to get any diffrent ideas from you.
Expert:  JOHN aka Eauto replied 3 months ago.

240 is too high..sounds like ya may have head gasaket failure... 198 to 210 is fine 240 is pushing the limits

Customer: replied 3 months ago.
We are blowing no coolant, what about a water pump impeller?
Customer: replied 3 months ago.
We are pulling a 45ft 20,000 lb toyhauler, so you beleive the temp should only be 210? What about on a 6% grade? what temp would you expect?
Expert:  JOHN aka Eauto replied 3 months ago.

very uncommon for failure but possible....any coolant loss?

Customer: replied 3 months ago.
No coolant loss, also ran the truck (Chevy Kodiak) up to 200dg and let cool and the radiator hose was soft after cooling. Would't the hose be hard if the head gasket was leaking?
Customer: replied 3 months ago.
There is a service bulletin on the impeller spinning on the shaft.
Expert:  JOHN aka Eauto replied 3 months ago.

is the coolant temp sensor accurate?

Customer: replied 3 months ago.
checked it with a heat gun.
Expert:  JOHN aka Eauto replied 3 months ago.

that would not explain it only spinning on the shaft when towing...but next step is to pull the water pump and check...

Customer: replied 3 months ago.
Would you please answer my temp questions, would like to know what temps you think are normal. Thank you!
Expert:  JOHN aka Eauto replied 3 months ago.

180-195 is normal 210 when pulling a load...anything over 220 would be considered over heat

Customer: replied 3 months ago.
have you ever had a bad head gasket but the truck has no coolant loss or change in coolant color or water in the oil?
Expert:  JOHN aka Eauto replied 3 months ago.

start by cleaning the coolant stack a mouth piece upgrade also helps we also have had bad luck with stant and aftermarket tstats try running a ac delco

Customer: replied 3 months ago.
We just installed a new radiator and used all GM parts...we have not changed the mouthpiece...sorta looks like it has been modified at some time....truck was built for Nascar team.
Expert:  JOHN aka Eauto replied 3 months ago.

pull the water pump and check the impeller then...i had a rash of bad stant t stat on llys it almost drove me crazy at one point

Customer: replied 3 months ago.
We put a new pump on yesterday...no change still heats up when under a load like 240��....rad hose soft, no puking coolant, no water in oil, no change in coolant...I think we are exhaused with ideas....can a dealer run any test that would prove its a head gasket?
Customer: replied 3 months ago.
Have you EVER had a head gasket problem that the only symptom was overheading and nothing else...i.g. puking coolant ect.....???
Expert:  JOHN aka Eauto replied 3 months ago.

yes where they have a slow internal leak...and they are not pushing exhaust into the cooling sstem ..not common but it happens

Customer: replied 3 months ago.
Yikes...somehow we need to get the truck 150 miles away to the only dealer who works on 4500....if we drive it empty and the temps run around 210ish will that potentialy cause more damage...should we have it towed?
Expert:  JOHN aka Eauto replied 3 months ago.

if it runs at 210 thats considered normal operating range..if it stays under 220 u should be fine