How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. Your Own Question
Lou P.
Lou P., ASE Certified Technician
Category: Chevy
Satisfied Customers: 4487
Experience:  building and driving chevy's since i was in the womb!!!! camaro and corvette enthusiest, access to factory diagrams and tsb's
27644750
Type Your Chevy Question Here...
Lou P. is online now
A new question is answered every 9 seconds

I have a 1996 Geo Prizm. Today while driving on a flat

Customer Question

I have a 1996 Geo Prizm. Today while driving on a flat highway in cruise control the engine suddenly accelerated and became disconnected from the drive chain, i.e. the engine was no longer delivering power to the wheels.
What could be the cause?
Submitted: 6 months ago.
Category: Chevy
Expert:  Lou P. replied 6 months ago.

Hello, my name is***** and i will do my best to assist you.I am going over your story now and will reply back soon with some info,thanks!

Expert:  Lou P. replied 6 months ago.

this sounds like there is an issue with the transmission, if you have a manual then the clutch may have failed, if you have an automatic then the transmission may have internal damage or no fluid. the issue is definitely the transmission though, hope this helps, Lou P.

Please take a second and click the STARS above and rate my service 4 or 5 stars if you feel I have been helpful and please request me in the future. Keep in mind that when you rate it does not end our conversation, you can still return here to me for follow up information if needed, Thanks for choosing just answer. Also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED! Thanks again , Lou P.

Customer: replied 6 months ago.
It is a manual 5 speed
Expert:  Lou P. replied 6 months ago.

then the issue is a slipping or broken clutch disc . that clutch is a mechanical connection between the engine and trans so when the engine free spins that means that either the clutch disc broke off the center splines, or a cv axle has broken to one of the front wheels (most likely come to think of it) or there is an internal trans failure which would have caused a lot of noise so i dont think thats it but still a possibility.

if both front cv axles do not have even pull the transmissions differential will free spin in the direction of the axle that has no resistance. what you need to do is put the front end up in the air and with the gear in 1st gear see if you can rotate either front wheel without the other one spinning, if you can , the one that spins is the faulty one. the axle could have come out of the trans or seperated. im not sure how much you know about cars so forgive me but if you google any of the parts i am talking about there will be plenty of pictures. hope this helps, Lou P.

Please take a second and click the STARS above and rate my service 4 or 5 stars if you feel I have been helpful and please request me in the future. Keep in mind that when you rate it does not end our conversation, you can still return here to me for follow up information if needed, Thanks for choosing just answer. Also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED! Thanks again , Lou P.

Customer: replied 6 months ago.
There was no noises, except for the engine revving up. The manual stick still moves smoothly. There is the usual tension on the clutch when I push and release it. When I put it in third gear the odometer responds even though I am not moving. There seems to be some soft noises when I put it in third /forth gears and slightly accelerate the engine. But the car does not move.
Customer: replied 6 months ago.
I don't ave a way to put it on a rack. I am trying to get an idea of whether to spend the money to tow it into the shop.
Expert:  Lou P. replied 6 months ago.

perfect, that means that it is a cv axle issue, because the output speed sensor is reading . either way trans or cv axle they are not easy to do with basic hand tools BUT i am now leaning toward the cv axle. they are like 70$ from autozone but are a pain sometimes in these models to change.

Expert:  Lou P. replied 6 months ago.

let me know if you need more help, Please take a second and click the STARS above and rate my service 4 or 5 stars if you feel I have been helpful and please request me in the future. Keep in mind that when you rate it does not end our conversation, you can still return here to me for follow up information if needed, Thanks for choosing just answer. Also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED! Thanks again , Lou P.

Expert:  Lou P. replied 6 months ago.

I have taken my time to answer your question the best I could and I will continue to help if you need follow up information , all I ask is that you PLEASE take a second to rate my service so I may receive my credit for assisting you. Thank you. Lou P.

Expert:  Lou P. replied 6 months ago.

Lawrence are you still needing help? did you get the car taken care of?