How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15201
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Have a 2006 hhr stick shift cranks great will not start have

Customer Question

have a 2006 hhr stick shift
cranks great will not start
have code reader hooked up not reading is there a computer reset someware have disconnected the battery to clear but still nothing showing
Submitted: 10 months ago.
Category: Chevy
Customer: replied 10 months ago.
how do i fix this car only has 158k miles have replaced the engine wiring harness plugs module coil and the sensor behind the starter
Customer: replied 10 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  david craig replied 10 months ago.

Hi Im David, are you getting rpms while cranking?

Customer: replied 10 months ago.
Nope
Expert:  david craig replied 10 months ago.

thats not good. and you cant communicate with the computer with a scan tool correct?

Expert:  david craig replied 10 months ago.

do you have a meter?

Customer: replied 10 months ago.
no the scanner is not firing up tried on my of my other cars works fine
Customer: replied 10 months ago.
have a meter
Customer: replied 10 months ago.
is there a reset button for the computer
Expert:  david craig replied 10 months ago.

no reset button for the computer. that would be too easy.

Expert:  david craig replied 10 months ago.

i need you to check a few things with your meter at the DLC connector

Customer: replied 10 months ago.
ok what is a DLC connector
Expert:  david craig replied 10 months ago.

where you plug the scan tool in

Customer: replied 10 months ago.
ok getting the meter
Expert:  david craig replied 10 months ago.

i need you to check for 12 volts dc at pin 16

check for a ground at pin 4

check for a ground at pin 5

check for 11.0 vdc at pin 7

Customer: replied 10 months ago.
have 6 pins
Customer: replied 10 months ago.
no power on 16
Customer: replied 10 months ago.
no pin 7 in the spot
Expert:  david craig replied 10 months ago.

what about the grounds for 4 and 5

Customer: replied 10 months ago.
no power at any pins
Customer: replied 10 months ago.
how do i check the grounds
Expert:  david craig replied 10 months ago.

you arent looking for power at 4 and 5 you looking for grounds. set the meter to ohms, and check the pins for ground.

Expert:  david craig replied 10 months ago.

put one meter lead on pin and the other to a nearby chassis ground

Expert:  david craig replied 10 months ago.

if its a good ground the meter will read 000

Customer: replied 10 months ago.
no not getting any readings
Customer: replied 10 months ago.
on any pins
Expert:  david craig replied 10 months ago.

take a pic of how the meter is set up and attach it to here.

Customer: replied 10 months ago.
ok pin 4 - 5 both read now
still no power on 16
there is no pin 7
checked the other pins using the ground 4-5 no power to any of them
Customer: replied 10 months ago.
dont have a way of taking a picture
Customer: replied 10 months ago.
ok pin 4 - 5 both read now
still no power on 16
there is no pin 7
checked the other pins using the ground 4-5 no power to any of them
dont have a way of taking a picture
Expert:  david craig replied 10 months ago.

ok, then you definitely got issues with the wiring harness.

Expert:  david craig replied 10 months ago.

check all the fuses for the ecm/pcm/ecu/ dlc ill try to find a diagram

Customer: replied 10 months ago.
just replaced it order from the dealer and installed it
have taken all the fuses out and checked everyone of them all good
the car ran for for about 125 miles and died had to tow it home
Customer: replied 10 months ago.
have checked all connections all tight
Expert:  david craig replied 10 months ago.

no rpms during crank =crank sensor/computer

no voltage from computer to dlc= wiring harness/computer.

when you turn the key to the run position(not start) can you hear the fuel pump run for a few seconds?

Customer: replied 10 months ago.
fuel pump work
Customer: replied 10 months ago.
just replaced it with new clutch
Expert:  david craig replied 10 months ago.

replaced what with a clutch?

Customer: replied 10 months ago.
transmission
Expert:  david craig replied 10 months ago.

ok now we need to check for spark

Customer: replied 10 months ago.
ok
Expert:  david craig replied 10 months ago.

do you have a spark tester?

Customer: replied 10 months ago.
Expert:  david craig replied 10 months ago.

ok then lets check for spark. get back to me when you have the results.

Customer: replied 10 months ago.
pulling the coil now
Expert:  david craig replied 10 months ago.

ok

Customer: replied 10 months ago.
great spark
Expert:  david craig replied 10 months ago.

ok. let check injector pulse. you have a noid light?

Customer: replied 10 months ago.
should i check them at the injectors
Expert:  david craig replied 10 months ago.

at the injector connectors

Expert:  david craig replied 10 months ago.

or if you dont have a noid light use a long plastic handled screw driver as a listening device. to hear each injector clicking.

Customer: replied 10 months ago.
sounds like they are working
Expert:  david craig replied 10 months ago.

ok. gotta walk the pooch check ya out in a few

Customer: replied 10 months ago.
k
Expert:  david craig replied 10 months ago.

when you crank the car does the security light go out?

Customer: replied 10 months ago.
goes out
Expert:  david craig replied 10 months ago.

ok. good. now when you turn the key to the run position(not start) does the check engine light come on?

Customer: replied 10 months ago.
all the lights come on
Expert:  david craig replied 10 months ago.

all the light come on and most should go back out. does the check engine light stay on?

Customer: replied 10 months ago.
all go out
except the engine light and brake
Expert:  david craig replied 10 months ago.

ok. well everything is working like it should. except it wont start and no power to dlc connector. check the cigarette lighter fuse or power outlet fuses. the dlc is tied into that circuit on a lot of vehicles.

Expert:  david craig replied 10 months ago.
Customer: replied 10 months ago.
is good 15 amp fuze
Expert:  david craig replied 10 months ago.

should be 20 amp. was it labeled frt aux pwr oultet?

Customer: replied 10 months ago.
ok just put a 20 amp in
crank but no start
Expert:  david craig replied 10 months ago.

ok, well there is definitely a wiring issue or a pcm issue. i would be more comfortable if you could put a noid light on the injectors to see if the pcm is sending pulses to the injectors.

Customer: replied 10 months ago.
i don't have a noid light just have a test light and hard to get into the connectors buried under the fuel rail
Expert:  david craig replied 10 months ago.

can you verify that you are getting fuel to the rail?

Customer: replied 10 months ago.
no fuel pressure at the rail
cranked the engine and depressed the schrader valve no pressure has a new fuel pump approx 800 miles ago
Customer: replied 10 months ago.
have moved all relays around
Expert:  david craig replied 10 months ago.

didnt you say the fuel pump is running?

Customer: replied 10 months ago.
turn the key with out starting and can hear it run
keep turning the key and you can smell gas
Expert:  david craig replied 10 months ago.

but no pressure at rail?

Expert:  david craig replied 10 months ago.

check the filter.

Customer: replied 10 months ago.
not as much as i would expect
Expert:  david craig replied 10 months ago.

or a kink in the lines somewhere.

Expert:  david craig replied 10 months ago.

how much gas is in the vehicle?

Customer: replied 10 months ago.
only filter is in the tank on the pump and flushed the tank out when we replaced ithard lines on fuel lines locked in1/2 tank
Expert:  david craig replied 10 months ago.

you need to hook up a gauge and check pressure at the rail. or if you think theres not enough pressure there by pressing in the schrader, then the only thing that can be wrong is the fuel pump.

Customer: replied 10 months ago.
found no dirt or sludge when replaced
Expert:  david craig replied 10 months ago.

where did you get the fuel pump from?

Customer: replied 10 months ago.
napa
Customer: replied 10 months ago.
dont have a pressure gage
Expert:  david craig replied 10 months ago.

you;re going to have to get one. harbor freight sells them very cheap.

Expert:  david craig replied 10 months ago.

im not going to recommend replacing the pump until i know what the key on pressure is.

Customer: replied 10 months ago.
would a bad fuel pump cause the ecm not to work
Customer: replied 10 months ago.
ill try dumping feul into the air inlet see if it fires off
Expert:  david craig replied 10 months ago.

the ecm is doing everything its supposed to be doing, except supplying 12vdc to the DLC connector. if you dont have 50-60 psi at the rail while cranking the engine, the pump is shot.

Expert:  david craig replied 10 months ago.

any luck?

Customer: replied 10 months ago.
the closest harbor freight is 55 miles from my house
will have to locate one and try the fuel pressure test
hope fully i will not have to drop the tank again not easy to get out
will let you know in next few days
Thanks and Hope you had a Happy ThanksgivingVisit My web site at WWATS.org
Wayne
Expert:  david craig replied 10 months ago.

ok. you might br able to get a loaner from autozone....and same to you.

Customer: replied 10 months ago.
just thought i might ask how can i get power to the ecm port so my tester works ????
can i run a 12 volt and splice into the wireThis is my sons car
Customer: replied 10 months ago.
will see if auto zone here has one
Expert:  david craig replied 10 months ago.

ok

Customer: replied 10 months ago.
just thought i might ask how can i get power to the ecm port so my tester works ????
can i run a 12 volt and splice into the wire
Expert:  david craig replied 10 months ago.

no. that will mess up the computer. you need to trace the wire from 16 to the pcm and find out where the open is.

Customer: replied 10 months ago.
ok thanks will try to check it out in the morning to cold and dark right now
Expert:  david craig replied 10 months ago.

ok

Customer: replied 10 months ago.
will get back to you in next few days
Expert:  david craig replied 10 months ago.

heres a pinout of the computer. its the same as the colbalt so dont worry

http://www.ecotecforum.com/forums/PCM/05cobalt22.htm

Customer: replied 10 months ago.
Thanks will check it out
Customer: replied 10 months ago.
how do i get in contact with you in a few days
Expert:  david craig replied 10 months ago.

right here. ill keep it open

Customer: replied 10 months ago.
thanks
Expert:  david craig replied 10 months ago.

you bet

Expert:  david craig replied 10 months ago.

checking in to see how its going

Customer: replied 10 months ago.
Ok so we put 4.5 gallons fuel in and purged the system just to see what would happen
the car started ran rough for about 5 mins then smoothed out
took to town approx. 18 miles filled tank.But none of the gages or speedometer are working
fuel showed a half of tank but not reads e and i know e does not mean enough
dumped a fuel injector cleaner in the tank
check all fuses again but no gages
do you have any ideas
Expert:  david craig replied 10 months ago.

give me a while to come up with a game plan.

Customer: replied 10 months ago.
thanks
Expert:  david craig replied 10 months ago.

no gauges are working?

Customer: replied 10 months ago.
none
just tach
Customer: replied 10 months ago.
all fuzes good
Expert:  david craig replied 10 months ago.

im going to pull a print.

Customer: replied 10 months ago.
k
Expert:  david craig replied 10 months ago.

here....it looks like without that 16 volts to the dlc connector, your serial data line for the gauges aint happening.

Customer: replied 10 months ago.
i need to follow the line to the fuse panel and find the break in the line
Expert:  david craig replied 10 months ago.

if you are absolutely certian each fuse on these prints are good, then you need to find out why theres not 12vdc at 16 on the DLC

Customer: replied 10 months ago.
ok will look into it poss.sunday after church
will advise you soon thanks
Expert:  david craig replied 10 months ago.

ok. youre welcome

Expert:  david craig replied 10 months ago.

any luck?

Expert:  david craig replied 10 months ago.

just checking in to see how its going

Customer: replied 10 months ago.
been snowing here have not a chance ito work on looking at maybe in next day or so
Thanks
Expert:  david craig replied 10 months ago.

ok.