How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask kalamykid Your Own Question
kalamykid
kalamykid, Shop Owner/ Tech
Category: Chevy
Satisfied Customers: 4024
Experience:  I HAVE OWNED MY OWN SHOP FOR OVER THREE YEARS. I HAVE THE TOOLS AND SOFTWARE TO ANSWERE ALMOST ANY Q
5629372
Type Your Chevy Question Here...
kalamykid is online now
A new question is answered every 9 seconds

Is this advice free? I had an account here and the mechanic

Customer Question

Is this advice free?
JA: The Chevy Mechanic's require payment for their services. It's way less expensive on JustAnswer than face-to-face would cost.
Customer: I had an account here and the mechanic stopped answering me so i canceled my subscription
JA: OK. To minimize me, please click the down arrow at the top right corner of this box.
Customer: And i guess you are doing the same.
JA: What is the model/year of your Chevy?
Customer: 90 blazer
JA: Are you fixing your Blazer yourself? What have you tried so far?
Customer: Yes. A lot.... Ignition parts, fuel parts, and sensors
JA: Are you certain it's the fuel pressure sensor that's in need of attention? What about the fuel rail? Have you checked it yet?
Customer: ?
JA: What confuses you?
Customer: I didn't say anytging about tge fuel pressure sensor
JA: Anything else you want the mechanic to know before I connect you?
Customer: Pr8blem is tgat it wants to die when in gear. It wouldn't start until today when i replaced the iacv
Submitted: 9 months ago.
Category: Chevy
Customer: replied 9 months ago.
Im not paying $28 to wait a day. It said someone was online and available.
Expert:  kalamykid replied 9 months ago.

I am here to try to help you tonight. Can you please tell me what is wrong and what you have done to try to correct the problem.

Customer: replied 9 months ago.
Right now it starts and runs at idle, which it didnt do for a while. There is white smoke from the exhaust, strong fuel odor under hood, and under load it wants to stall
Expert:  kalamykid replied 9 months ago.

What size engine do you have in your blazer?

Customer: replied 9 months ago.
350
Expert:  kalamykid replied 9 months ago.

So this is a full size blazer correct?

Customer: replied 9 months ago.
1990 tbi
Expert:  kalamykid replied 9 months ago.

Can you take the air cleaner off so you can see all of the tbi unit please?

Customer: replied 9 months ago.
I was under hood earlier, cant right now
Expert:  kalamykid replied 9 months ago.

What I need you to look for will be to see if there is any fuel leaking around the injectors with the ignition switch turned to the run position and the engine not running. If there is no leaks, start the engine and see if the injectors are dribbling fuel out or if you see a nice cone shaped spray?

Customer: replied 9 months ago.
Short answer is the left one ( when looking at tge front) is dribbling fast and right has cone....while youre replying ill give you the long story...
Expert:  kalamykid replied 9 months ago.

Does fuel dribble out of the left injector with the engine not running?

Customer: replied 9 months ago.
Bought the truck a few months ago, started right up. Failed emissions, so replaced egr and passed. Everytime id start it after that it would take longer and eventually would only start when pressing gas pedal. Replaced plugs, wires, cap, rotor, tps, map, ignition module, fuel filter, injectors and diaphragm in tbi. Still no change. Called over mechanic who rewired plug wires and advanced timing and it started but rpm was ridiculously high. Took it for test drive and died 2 min later and wouldn't start. Had it towed to AAA repair shop who replaced tps again and reset timing. Back to only starting with gas pedal. This morning i started taking apart the tbi to clean it and figured id replace the idle air control valve and it worked. Starts right up and stays running on its own. Was about to drive it and when i put it in gear it was close to stalling. White smoke increases with pedal pressed. Yes fuel will dribble when in on but not running position. Hope that helps
Expert:  kalamykid replied 9 months ago.

Just to be clear, will fuel come out of the left injector with the engine not running or turning over, but the ignition switch is in the run position?

Customer: replied 9 months ago.
Expert:  kalamykid replied 9 months ago.

Will fuel come out of the injector with the ignition switch turned off?

Customer: replied 9 months ago.
No
Expert:  kalamykid replied 9 months ago.

Look very carefully at the wires from the injector all the way to the front where the wires run through the rubber gromit and out the front of the tbi and see if the wire have been pinched by the air cleaner spacer. if you have fuel coming out of the left injector then there has to be a ground going to the injector on the green or the blue wire. these two wires should only have a pulsing ground from the pcm. The red and white wire will have constant power on them with the ignition switch in the run position.

Customer: replied 9 months ago.
just inspect all wires at fuel injectors all the way through? Will have to wait until tomorrow. If everything ok, any other suggestions? You think the lower rpm in drive/reverse is a fuel delivery issue?
Customer: replied 9 months ago.
Fyi there is a wire from what i think is the fuel pump relay that is not connected to anything...has a small clasp. Not sure where it goes. Could that be anything?
Expert:  kalamykid replied 9 months ago.

I believe that the left injector is dumping way to much fuel and you are really only running on 3 cylinders. If the wires all look good, then you will need to test the injector for an internal short, or you may have to replace the pcm.

Customer: replied 9 months ago.
Im trying to attach pictures...i don't see them here
Customer: replied 9 months ago.
Here is the relay
Expert:  kalamykid replied 9 months ago.

I see a pic of the tbi. The blue wire will be the one you need to look at. I am willing to bet the blue wire has rubbed on the air cleaner spacer and is shorting out on it.

Customer: replied 9 months ago.
Do i need to take off the tb to check the wires all the way through?
Expert:  kalamykid replied 9 months ago.

No just remove the air filter spacer that sits on top of the tbi.

Customer: replied 9 months ago.
Ok ill hit you up tomorrow morning. Thanks and goodnight
Expert:  kalamykid replied 9 months ago.

You are very welcome. Have a good night yourself.

Customer: replied 9 months ago.
Picture with key in on position. all wires look ok. After crank both spray erratically
Customer: replied 9 months ago.
Wires picture. I just took the vacuum hose off for a better pic
Expert:  kalamykid replied 9 months ago.

Have you had the injectors out of the throttle body?

Customer: replied 9 months ago.
replaced them not long ago
Expert:  kalamykid replied 9 months ago.

Please unplug the left injector, have some one turn the ignition switch to run an take another pick f the left injector for me as soon as the switch is turned to run.

Customer: replied 9 months ago.
While engine running
Customer: replied 9 months ago.
Left only while running
Expert:  kalamykid replied 9 months ago.

I can not see the left injector to see if fuel is coming out of it.

Expert:  kalamykid replied 9 months ago.

Do you have a digital voltmeter?

Customer: replied 9 months ago.
No sir. I have a small mp3 vid but cant upload here.
Customer: replied 9 months ago.
Picking one up in a few minutes
Expert:  kalamykid replied 9 months ago.

Can you get a digital volt meter so we can do some testing. The left injector looks like it is still dumping fuel into the throttle body even with the wires unplugged. I need to know if the injector is bad or if it is just a leaking seal. I need you to take some ohms readings to make sure we fix the correct thing.

Expert:  kalamykid replied 9 months ago.

You may as well get a throttle body gasket set, as I do know that the injector will have to come out, I do not know if the injector itself is bad, but more then likely it is.

Customer: replied 9 months ago.
I coan do both...so we are rebuilding and cleaning the TB?
Expert:  kalamykid replied 9 months ago.

Yes. We have to get the left injector to stop leaking.

Customer: replied 9 months ago.
PCV is also nasty, gonna do that too while im here. This is what im getting right now. Let me know how to use the voltmeter so i can do that and get back to you with results
Expert:  kalamykid replied 9 months ago.

yes those are the things you will need.

Customer: replied 9 months ago.
Ok got the voltmeter now how do i use this thing?
Expert:  kalamykid replied 9 months ago.

You need to set it to ohms, hold the black test lead to the metal housing of the throttle body, and hold the red test lead to the pin on the top of the injector where the blue wire goes. Tell me what the reading is on the meter please.

Expert:  kalamykid replied 9 months ago.

the ohms setting is where the horse shoe looking thing is.

Customer: replied 9 months ago.
What key position?
Expert:  kalamykid replied 9 months ago.

Off

Expert:  kalamykid replied 9 months ago.

With the injector unplugged.

Customer: replied 9 months ago.
Not doing anything. Just shows this
Expert:  kalamykid replied 9 months ago.

What does the meter read when you touch the two test leads together as well as if they are apart?

Customer: replied 9 months ago.
Same thing as in picture. Voltmeter doesnt change
Expert:  kalamykid replied 9 months ago.

Set it to 200k and check it again please.

Customer: replied 9 months ago.
Doesn't do anything. I put the black to the tb housing and touched each injector. Got no change from the picture. Something with the voltmeter isnt on or working
Expert:  kalamykid replied 9 months ago.

slow down. Take the two test leads and touch them only to each other and tell me what you are getting please. Send me a pic of the two test leads touching so I can see the leads as well as the reading on he meter please.

Customer: replied 9 months ago.
Reads 0.00 if i touch them together
Expert:  kalamykid replied 9 months ago.

If you take them apart what does it read?

Customer: replied 9 months ago.
Expert:  kalamykid replied 9 months ago.

Now touch each of the two pis on the top of the injector and see what you gt.

Expert:  kalamykid replied 9 months ago.

black on one pin red on the other.

Customer: replied 9 months ago.
0.00 on both injectors
Expert:  kalamykid replied 9 months ago.

ok. Now hold the black lead on the tbi housing and the red lead on the left injector pin on the left side, the pin that the blue wire would go to.

Customer: replied 9 months ago.
Nothing, just the 1
Expert:  kalamykid replied 9 months ago.

You need to pull the injector out and see if the seals are leaking around the bottom of the injector.

Customer: replied 9 months ago.
At 200 it reads 0.2, at 200k it reads 00.0
Customer: replied 9 months ago.
Sorry...that is when touching leads together. Still only the 1 on any setting when touching injectors
Customer: replied 9 months ago.
Doing it now, a lot of fuel in the regulator housing
Customer: replied 9 months ago.
Left injector
Expert:  kalamykid replied 9 months ago.

Replace the injector.

Customer: replied 9 months ago.
What do you see? This is a new one.
Customer: replied 9 months ago.
It is dry
Expert:  kalamykid replied 9 months ago.

The seals are in good shape, and there is no short in the connectors to a ground. So the pental in the injector has to be why it is leaking.

Customer: replied 9 months ago.
Ok...should be under warranty so ill do that and rebuild/clean tb while im at it. Any suggestions or recommendations for doing that.
Expert:  kalamykid replied 9 months ago.

Just clean the old gasket off, and put it back together. you do not need to clean anything but the old gasket off.

Customer: replied 9 months ago.
If you're talking about the one I had to take off to get to the injectors, I already did that one when I replaced the fuel pressure regulator, just checked it and its still good and dry. Thanks will get back to you after replacing the injector. After i install the new one do you want me to get back to you right after, or put it all back together and check spray pattern then let you know?
Expert:  kalamykid replied 9 months ago.

Put it back together, and do not plug the left injector up and see if the injector is still leaking fuel out of it with the engine running.

Customer: replied 9 months ago.
not leaking now. Tried it unplugged and key on then plugged and key on and turned it over. No leaaks, running smooth
Expert:  kalamykid replied 9 months ago.

Will it drive now?

Customer: replied 9 months ago.
Fixing pcv and grommet now, then will attempt
Expert:  kalamykid replied 9 months ago.

ok

Customer: replied 9 months ago.
Disregard. No improvement in drivability. Injector spraying better though
Expert:  kalamykid replied 9 months ago.

I do not see any fuel coming out of the left injector in the pic you just sent.

Customer: replied 9 months ago.
Pic isnt good. Good cone shape pattern on both now. Same hesitation though, and more so when in drive/reverse. So same problem as my initial from last night
Customer: replied 9 months ago.
If you zoom in on this one you can see the mist
Expert:  kalamykid replied 9 months ago.

Now that you have the fuel right, you will need to set the timing.

Customer: replied 9 months ago.
Thats beyond my knowledge or abilities
Expert:  kalamykid replied 9 months ago.

When you go to start the engine after it has warmed up, does it turn over good or does it lag?

Customer: replied 9 months ago.
Turns over quickly, w/o pressing gas pedal.
Expert:  kalamykid replied 9 months ago.

If you look down along the passenger side of the distributor at its base there is a bolt at about 7 oclock. this is the hold down and bolt that holds the distributor tight. Loosen the bolt about three turns and rotate the distributor counter clockwize about 10 degrees and snug the bolt down. Then see how it starts.

Customer: replied 9 months ago.
Turned CCW as you said. Not much different at 10 degreess. Rotated a little more and it was rough, and stalled after putting it in drive. Turned it clockwise and no change from original. Still smoking from exhaust when pressing on gas pedal
Customer: replied 9 months ago.
Could the firing order be off?
Customer: replied 9 months ago.
See pic attached. If what i circled is the part of the cap that covers the ignition module then thats in the back.
Expert:  kalamykid replied 9 months ago.

No pic come through.

Customer: replied 9 months ago.
Expert:  kalamykid replied 9 months ago.

The ignition module should be at the back, and number one should be where the pic said it should be.

Customer: replied 9 months ago.
Ok firing order is good
Expert:  kalamykid replied 9 months ago.

With all the fuel that the left injector was dumping into the intake, you need to replace all the spark plugs. When you have them out, unplug the injectors and turn the engine over a few good times before you put the new plugs in. the plugs may be to fouled and not firing correctly.

Customer: replied 9 months ago.
I was just thinking about pulling them and checking. That'll have to be next weekend. Thanks
Customer: replied 9 months ago.
When you say unplug the injectors do you mean take off the connectors or take out the injectors?
Expert:  kalamykid replied 9 months ago.

Just disconnect the plug on top of them.

Customer: replied 9 months ago.
Back at it again. 1st one i pulled #2 cylinder. Never seen a plug this black
Expert:  kalamykid replied 9 months ago.

What do the rest of them look like? Can you send me a pic of all of them please?

Customer: replied 9 months ago.
They all looked like that, 2 had oil on the threads. I replaced them all and the o2 sensor. Ran much better. Just took it for a test drive, a lot more whitish smoke and started to hesitate like engine power not fuel or ignition. Heard a little pop from under the hood, popped it up and there is smoke coming from the exhaust manifold at #2 cylinder.
Expert:  kalamykid replied 9 months ago.

Now that you have driven it, pull the plugs back out please and redo the comp test.

Customer: replied 9 months ago.
Comp test? Compression? Never did that...how?
Expert:  kalamykid replied 9 months ago.

It would be nice to see a pic of each plug and to know what plig came out of what cylinder to please.

Customer: replied 9 months ago.
Ok. We labeled each one so we can do that for the old plugs. New ones in there now will have to wait until tomorrow
Expert:  kalamykid replied 9 months ago.

I am sorry. To do a comp test you have to get a compression tester that will screw into the spark plug hole. then when you turn the engine over the gauge will tell you how much pressure you have in each cylinder.