How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 16033
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

I have no clue got fuel injection cleaning from Walmart and

Customer Question

i have no clue got fuel injection cleaning from Walmart and it has not run since I had issues with it idling when the ac was cut on for a while
JA: Has the vehicle turned into a gas hog? And how does it start -- same as usual?
Customer: drove to tenn from va 700 miles and then it sounded like a lawnmower when idling and shut off occasionally
JA: What is the model/year of your Chevy?
Customer: it is not starting at all now
JA: What year is your Chevy?
Customer: had codes read before fuel injection cleaning and it came back p0100 p0121 2006 fuel pressure sensor fail throttle pressure system fail multiple misfires MAF sensor fail
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: yes and ive tried to replace throttle body,clean original throttle body, cleaning MAF sensor, changed spark plugs, changed coil packs and rubber boots
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 1 year ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 1 year ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you.

what is the year,make and model?

what engine do you have?

Customer: replied 1 year ago.
2006 chevy Malibu 2.2 l ecotec 4 cyl
Expert:  Tim's Auto Repair replied 1 year ago.

ok,,please stand by

Customer: replied 1 year ago.
any chance you think this can be caused by hydro/vaporlock as a result of fuel injection cleaning
Expert:  Tim's Auto Repair replied 1 year ago.

i wouldnt think a vapor lock,,no..

Expert:  Tim's Auto Repair replied 1 year ago.

tell me,,are you sure it gave a p0100 code?

Customer: replied 1 year ago.
that and the throttle body position one , fuel pressure system and misfire one too
Expert:  Tim's Auto Repair replied 1 year ago.

give me all the codes numbers you got..

p0100 is not reliant to this 2.2 engine

Customer: replied 1 year ago.
not p0100 but p0101, p0121, p0451, p0496 and p0300
Customer: replied 1 year ago.
this was before I got fuel injection cleaning though not sure what they are now car was running at that moment
Expert:  Tim's Auto Repair replied 1 year ago.

fuel injection cleaning isnt going to do anything

Expert:  Tim's Auto Repair replied 1 year ago.

how does it run now,,is it running good?

does it only do this when the engine is hot?

please explain

Customer: replied 1 year ago.
it is not starting at all
Customer: replied 1 year ago.
turns over and sounds really annoying and different but is not starting
Customer: replied 1 year ago.
ive tried to replace throttle body,clean original throttle body, cleaning MAF sensor, changed spark plugs, changed coil packs and rubber boots
Expert:  Tim's Auto Repair replied 1 year ago.

oooh,,i see..

does it have a spark on the plugs?

will it start with a prime[starting fluid or a little fuel into the throttle body?

Customer: replied 1 year ago.
no and spark plugs were not getting a spark which is why I changed coil packs
Customer: replied 1 year ago.
I'm not sure if they are still not getting one or not
Expert:  Tim's Auto Repair replied 1 year ago.

ok

replace the crank sensor

Customer: replied 1 year ago.
starting fluid will not start
Expert:  Tim's Auto Repair replied 1 year ago.

i would think you have a bad crankl sensor

Customer: replied 1 year ago.
now is the coil packs the thing that attachs to the plugs or the assembly
Customer: replied 1 year ago.
because I replaced the assembly the thing on top of it that was attached to plug I unattached it with alley keys and reused on new one
Expert:  Tim's Auto Repair replied 1 year ago.

the coil packs or on the coil housing

Expert:  Tim's Auto Repair replied 1 year ago.

it is replaced as a unit

Customer: replied 1 year ago.
this is what I replaced
Expert:  Tim's Auto Repair replied 1 year ago.

how many miles is on that engine?

Expert:  Tim's Auto Repair replied 1 year ago.

looks like the coil

Customer: replied 1 year ago.
however their is a electrical component on top of it that I took off the old and reused
Customer: replied 1 year ago.
123k
Expert:  Tim's Auto Repair replied 1 year ago.

ok

i would think your problem here is the crank sensor..or,it may have jumped time on the timing chain

Customer: replied 1 year ago.
crankshaft sensor?
Customer: replied 1 year ago.
as far as timing will replacing timing belt fix it ?
Expert:  Tim's Auto Repair replied 1 year ago.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/ey7s1dzfyxy3k6n/0904-imapal-P0121.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/ey7s1dzfyxy3k6n/0904-imapal-P0121.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 1 year ago.
replace crank sensor, maf sensor and coil pack
Expert:  Tim's Auto Repair replied 1 year ago.

no

you say you already replaced the coil pack and maf sensor...correct

Expert:  Tim's Auto Repair replied 1 year ago.

i think the crank sensor is your problem.

Customer: replied 1 year ago.
I cleaned the maf sensor not replaced
Expert:  Tim's Auto Repair replied 1 year ago.

ok..the maf wouldnt make it not have a spark

Customer: replied 1 year ago.
ok
Expert:  Tim's Auto Repair replied 1 year ago.

so,,i would think the maf is the problem

Customer: replied 1 year ago.
you think it is or isn't the MAF?
Customer: replied 1 year ago.
only reason I haven't replaced it because I cant find out what type of tool I need to take it off its weird
Expert:  Tim's Auto Repair replied 1 year ago.

i dont think it is the maf,,a maf wouldnt cause it not to have a spark,,you say it doesnt have a spark

thanks