How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Chevy
Satisfied Customers: 35507
Experience:  35 years experience with ASE Certs
7276279
Type Your Chevy Question Here...
Ron is online now
A new question is answered every 9 seconds

I did an oil pan gasket .now car 't have no park selector

Customer Question

I did an oil pan gasket .now car don't have no park selector indicator to start
JA: Is this your first time dealing with this issue? What size is your engine?
Customer: yes 3.5
JA: What is the model/year of your Chevy?
Customer: 2007 impala
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: are you a person or a computer
JA: No. I'm the Chevy Mechanic's Assistant.
Customer: ok yes
JA: Anything else you think the mechanic should know?
Customer: I check all fuses wires grounds
Submitted: 12 months ago.
Category: Chevy
Customer: replied 12 months ago.
battery was removed for safety.
Expert:  Ron replied 12 months ago.

Hello and thank you for your question,

When you say you have no selector are you saying the Selector is blank?

Dose the engine not crank?

Customer: replied 12 months ago.
no
Customer: replied 12 months ago.
also no power to windows or signals
Expert:  Ron replied 12 months ago.

So this all started after the pan gasket was replaced?

Have you scanned the computer system for any fault codes?

Customer: replied 12 months ago.
the selector don't show if it on anything u0140 no body control comunication
Customer: replied 12 months ago.
we didn't do any thing for the first fee yet
Expert:  Ron replied 12 months ago.

There is one Ground that can affect these systems that you need to check. The ground is the G111 that connects to the bell hosing just above the starter. Check it and se if its clean and tight . Let me know what you find and we can work from there if need be.

Customer: replied 12 months ago.
already did that
Expert:  Ron replied 12 months ago.

So I assume its in place and tight correct. Is the PRNDL blank?

Customer: replied 12 months ago.
just the numbers and letters not the circle around the numbers or letters
Expert:  Ron replied 12 months ago.

Okay lets start with checking this system first. See the steps in the link below, Run these steps and let me know the results.

https://dl.dropboxusercontent.com/u/104923897/PRNDL%20Jul%2026.pdf

Customer: replied 12 months ago.
check good
Customer: replied 12 months ago.
also I have no brake or signals
Customer: replied 12 months ago.
i have to step out i don't know how this works but i have to go .we didn't get any where at all
Expert:  Ron replied 12 months ago.

The one other thing that all of these system share is the BCM, was it disturbed at all during this repair?

Customer: replied 12 months ago.
Nothing was moved
Customer: replied 12 months ago.
Do you know of any problems with the body computer having issues on this car
Expert:  Ron replied 12 months ago.

In most cases if the BCM has a problem it will set a fault code.Unfortunately I suspect something is loose here but I do not think Im going to be able to fix this from here. I will open the post back up for you and perhaps someone else may have something to offer.

Customer: replied 12 months ago.
Ok
Customer: replied 12 months ago.
IT WAS THE BODY CONTROL MODULE
Customer: replied 12 months ago.
I WANT A CREDIT BECAUSE YOU GUYS WAS NOT IN ANY WAY HELP FULL AT ALL