How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Chevy
Satisfied Customers: 24171
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Chevy Question Here...
Dan is online now
A new question is answered every 9 seconds

I have an 03 chevy silverado 1500 5.3l. When i go to start

Customer Question

I have an 03 chevy silverado 1500 5.3l. When i go to start it it turns over and wants to start but im not getting any ignition. I have fuel pressure and my battery is charged. I also have new sparkplugs ans wires on it. Any clue what it could be?
Submitted: 1 year ago.
Category: Chevy
Expert:  Dan replied 1 year ago.

Hello, my name is***** you tested fuel pressure or checked for spark? Thanks

Customer: replied 1 year ago.
How would I check for spark? Yes I have checked the fuel pressure and the fuel pressure regulator.
Expert:  Dan replied 1 year ago.

They have spark testers you can buy from parts store for around $15 or remove plug with coil attatched, ground it out and watch for spark. Let me know, thanks.

Customer: replied 1 year ago.
i have spark
Expert:  Dan replied 1 year ago.

What was fuel pressure reading?

Customer: replied 1 year ago.
Some how i get fuel to the rails but the pressure is 0
Expert:  Dan replied 1 year ago.

Replace the fuel filter, if problem still exists verify pump has good power/ground when trying to start if so replace the fuel pump. I'd also make sure you have fuel in the tank. Let me know if you have more questions, thanks.

Customer: replied 1 year ago.
I dont know if this would have anything to do with it but when I turn the key but not crank it nothing showes up on the instrument cluster except the check engine light. Could something just be unpluged?
Expert:  Dan replied 1 year ago.

That is definitely a problem. Start by checking all of the fuses if good next step is to check power/grounds on the PCM. If power/grounds are good that would point toward a problem with the PCM which would require going to dealer for fix. Let me know how the fuses look or if you have more questions, thanks