How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 29523
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

2004 Chevrolet Silverado 1500 starts, but sometimes turn

Customer Question

2004 Chevrolet Silverado 1500 starts, but sometimes turn signals and tachometer will not work with engine running. Sometimes engine will not turn over when key is turned to start position except if I manually jump starter relay. Also cruise control may or may not work with above conditions. Cruise control, on occasion, when engaged has caused engine to turn off and not restart.
Submitted: 1 year ago.
Category: Chevy
Expert:  GM Tech (Cam) replied 1 year ago.

Hi there, I am Cam. I am sorry to hear about your issue.
With your truck, do you get any warnings on the dash when this happens?

Also when you manually jump the starter, I am assuming it remains running properly?

Customer: replied 1 year ago.
Whenever I manually engage the relay with the switch in the on position the truck will start, but the tachometer and turn signals won't work. If I turn the switch off and try to start the truck normally, the truck will not start. I have no indications that this will happen except the turn signals and tachometer quit working.
Expert:  GM Tech (Cam) replied 1 year ago.

Do you have anything aftermarket installed like a remote starter or such?

Customer: replied 1 year ago.
No, none installed. However when I bought the truck it did have an aftermarket electric cooling fan installed but I had it replaced with stock cooling fan.
Customer: replied 1 year ago.
This problem is intermittent but it does seem to be getting worse.
Expert:  GM Tech (Cam) replied 1 year ago.

I am honestly thinking there is a bad connection, and my first thought is the ignition switch, which is know for issue on these. with how cheap the switch is, 40$ or so from GM, I would just replace it. Attached are directions.

Other places to look are the area under the fuse block under the hood for corrosion, mice, rats, squirrels, other rodents. Check the grounds on the frame under the drivers door.

Customer: replied 1 year ago.
Is there more than one ground? If not, wouldn't a bad ground cause all the systems to shut down?
Expert:  GM Tech (Cam) replied 1 year ago.

There are many ground wires, under the drivers door on the frame are 3 that are common for issue. Ground issues cause VERY strange issues so it may not cause everything to shut down.

Customer: replied 1 year ago.
I'll give it a try and let you know.
Expert:  GM Tech (Cam) replied 1 year ago.

Sounds good.

Please bookmark this page so you can easily navigate back to it so we can continue the discussion. This is done by pressing (CTRL D on PC and CMD D on Mac). You can reply at any time for follow up information regarding this issue, even after you rate the site and I will reply.

Customer: replied 1 year ago.
Are the grounds outside or inside the cab & approximately where are the located?
Expert:  GM Tech (Cam) replied 1 year ago.

Outside, and ont eh ear of the frame under the drivers front door.

Customer: replied 1 year ago.
Ok, thank you. I'm going to clean & inspect the grounds, replace the ignition & starter relay along with cleaning their contacts. Hopefully this will correct the problem.
Expert:  GM Tech (Cam) replied 1 year ago.

Sounds good.

Thank you for allowing me to assist you. Please rate my answer 3-5 and feel free to ask any follow up questions regarding this issue you may have.

Customer: replied 1 year ago.
I have replaced the ignition switch and starter relay. I found 3 ground wires going to 2 bolts under drivers side exterior. I cleaned the bolts, washers, wire lugs, & frame well. Reassembled with no difference. Tachometer & turn signals still not working. Will not crank unless I manually depress relay.
Expert:  GM Tech (Cam) replied 1 year ago.

Does the heater fan work when this happens?

Have you taken off the cover to the fuse block to inspect under it?

Customer: replied 1 year ago.
The fan only works on level 5, not levels 1-4 though. I have not inspected the fuse block. I am going to do that in the morning.
Expert:  GM Tech (Cam) replied 1 year ago.

Does the fan work on 1-4 when it starts properly with the key?

Customer: replied 1 year ago.
The problem is still not resolved. I still need your help.
Expert:  GM Tech (Cam) replied 1 year ago.

Yes, I need to know if when the fan is working on 1-4, does the truck start normally?