How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Chevy Technician
Category: Chevy
Satisfied Customers: 17159
Experience:  15 years GM master tech
19513769
Type Your Chevy Question Here...
Gary is online now
A new question is answered every 9 seconds

02 1500 5.3 low fuel pressure barely ran. Installed new fuel

Customer Question

02 1500 5.3 low fuel pressure barely ran. Installed new fuel pump,regulator and filter. Still runs horrible idle about 450 hold to the floor get about 1100 rpms also cleaned mass air
Submitted: 2 years ago.
Category: Chevy
Expert:  Gary replied 2 years ago.

I am sorry your having this problem

what is the fuel pressure reading key ON engine OFF with a fuel pressure gauge ?

Customer: replied 2 years ago.
54 KO 42 KOF
Expert:  Gary replied 2 years ago.

if you pull out the 2 front O2 sensors will it still not go over 1100 rpms ?

Customer: replied 2 years ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Gary replied 2 years ago.

will it ?

Customer: replied 2 years ago.
No is dosent
Expert:  Gary replied 2 years ago.

ok will it rev up with the MAF unplugged ?

is the MAF clean and nothing blocking the center of the MAF ?

are there any codes set at all ?

with 54 PSI key ON engine OFF that should be enough fuel pressure

Customer: replied 2 years ago.
Will not fev I cleaned mas checking codes
Customer: replied 2 years ago.
Crank sensor and mas cause unplugged changed crank when it first came in
Customer: replied 2 years ago.
Smells rich egr?
Expert:  Gary replied 2 years ago.

egr would not stop it from going over 1100 rpm's

can you do a compression test on all 8 cylinders ?

Customer: replied 2 years ago.
take awhile how long you available?
Expert:  Gary replied 2 years ago.

i will be here for a while longer

i mean you tried the O2 sensors out and the fuel pressure is good

then either the compression is low or the MAF or MAP sensor are causing this issue

are there any throttle codes set ?

Customer: replied 2 years ago.
130-180
Expert:  Gary replied 2 years ago.

that compression should be fine for it to run

can you get it to rev up over 1100 rpm by adding carb cleaner down the throttle body ?

Customer: replied 2 years ago.
It's only running on 2&3
Expert:  Gary replied 2 years ago.

only cylinder 2 and 3 you mean ?

Customer: replied 2 years ago.
no injector pulse
Customer: replied 2 years ago.
Changed crank sensor
Expert:  Gary replied 2 years ago.

at the crank sensor with the key ON does one wire show 12 volts and does another wire show a good ground ?

it was doing this before you changed the crank sensor ?

Customer: replied 2 years ago.
Only code was crank sensor and I change it no differents
Expert:  Gary replied 2 years ago.

ok at this point with a new crank sensor and good fuel pressure and compression good and just 2 cylinders firing if the grounds are all clean and tight on this engine i would have to say to try another computer next

you have just about eliminated everything else

Customer: replied 2 years ago.
Ok that's where I was going next
Expert:  Gary replied 2 years ago.

it really is the only thing left

pick one up and have it programmed then relearn the theft system and see how it runs