How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 16036
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

Chevrolet Silverado 1500: I have no start no spark to ICM no

Customer Question

I have no start no spark to ICM no pulse to coil,read on line how to check cranksensor getting 12 volts to plug pieces plus wire getting 9.6 v all time cranking it by hand
Submitted: 2 years ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 2 years ago.
oktell me,what all have you replaced?how and when did this problem first begin?
Expert:  Tim's Auto Repair replied 2 years ago.
does the distributer rotor turn when you turn the engine?
Expert:  Tim's Auto Repair replied 2 years ago.
be sure of the engine size.it cant be a 4.6..
Customer: replied 2 years ago.
coil, checked ICM was good, cranksensor was scand code bad,dist turns,new cap rotor, yes it 4.3 sorry, no fire to icm, coil,distributor, coil,ICM,cranksensor all getting 12 volts, no start
Expert:  Tim's Auto Repair replied 2 years ago.
how did you check the icm?how and when did it first loose spark?
Expert:  Tim's Auto Repair replied 2 years ago.
how did you check the icm?how and when did it first loose spark?
Customer: replied 2 years ago.
it was running good, went to crank it 1day hasn't started since
Expert:  Tim's Auto Repair replied 2 years ago.
how did you test the icm?
Customer: replied 2 years ago.
took the ICM to a same yr. Same eng. it cranked up
Expert:  Tim's Auto Repair replied 2 years ago.
i see..so,,you do see that you have no spark at all on the plugs?
Customer: replied 2 years ago.
Yes
Customer: replied 2 years ago.
I am not getting a pulse signal at the coil or ICM. they are getting 12 volts at each plug.
Expert:  Tim's Auto Repair replied 2 years ago.
ok,tap on that icm with the handle of a screw driver or something and see if it will start..i think your problem is the icm,,it should have a spark if the distributer is turning ,thereis battery voltage to the + side of the coil,and the icmis gpood
Expert:  Tim's Auto Repair replied 2 years ago.
do you have a spark from the coil,,on the coil wire?
Customer: replied 2 years ago.
No
Expert:  Tim's Auto Repair replied 2 years ago.
did you try another icm?
Customer: replied 2 years ago.
Are you still there
Expert:  Tim's Auto Repair replied 2 years ago.
yes...the sie is trying a new program,,i will be slower than normal,,sorry
Customer: replied 2 years ago.
K
Expert:  Tim's Auto Repair replied 2 years ago.
let me know what happens
Customer: replied 2 years ago.
What do you mean ?
Customer: replied 2 years ago.
Hay been on for over one hour no answers
Customer: replied 2 years ago.
Do not process the charge I am getting of line !! Waited for 1&1/2 hours no answer
Expert:  Tim's Auto Repair replied 2 years ago.
hiare you there..the site is having some problems,,and,i have been off line..tell me where you are on this onethanks