How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask kalamykid Your Own Question
kalamykid
kalamykid, Shop Owner/ Tech
Category: Chevy
Satisfied Customers: 4026
Experience:  I HAVE OWNED MY OWN SHOP FOR OVER THREE YEARS. I HAVE THE TOOLS AND SOFTWARE TO ANSWERE ALMOST ANY Q
5629372
Type Your Chevy Question Here...
kalamykid is online now
A new question is answered every 9 seconds

10 blazer: running rich..rough idle and surge at cruise

This answer was rated:

i have a 96 chevy s-10 blazer. after many questions and answers i have one that may help get a solid one. after thinking about my issues with running rich all the time and the rough idle and surge at cruise. i bought this truck about 4 years ago. a week after i had it the engine spun a main and the garage they used put in a used engine. could it be all this time that the motor they got didnt match up to the computer in my truck or something of this nature? i have had the same rough idle and such ever since that time. i know the computer is suppose to match with the numbers in the vin and a new one has to be flashed to that number.

kalamykid :

Is this a vortec 4.3 or a tbi 4.3?

Customer:

4.3 seq fuel injection. the ones with the spider and poppets under the upper intake

kalamykid :

Can you tell me what all you have done to the truck to this point please?

Customer:

ok this may take a bit

kalamykid :

ok that is fine. I just need to know what all has been done so I do not have you double checking things.

Customer:

fuel pump a year ago along with the fuel regulator,wires plugs 2 weeks ago,new downstream o2s about 2 months ago,upstream o2s about 6 months ago along with distributor,intake gaskets. tps has been replaced,map has been replaced, temp sensor new,maf cleaned more than 3 times,transfer case switch and actuator. replaced the coil about 2 years ago. think thats it. oh and heater core about 4 months ago

kalamykid :

So you have not pulled the upper intkae off to see if the spider is leaking?

Customer:

i never saw any signs of leaks the manifold was all the same color when i pulled it out. i did a pressure check on the fuel a few days ago and it is 60 with the key on and 53 with the engine running and doesnt loose any pressure after it sits

Customer:

i suppose it could be leaking. it does have 130000 miles on it

kalamykid :

I would pull the upper intake off and reconect the fuel lines to the spider and just turn the key on and off a few times and see if the regulator or sdier is leaking.

kalamykid :

Make sure to warm the engine up first, and pull the coil wire off of the coil so the engine does not try to start when you test the fuel pressure.

kalamykid :

then see if you see any drips around the spider or the fuel pressure regulator on the back side of the spider.

Customer:

i have had the spider assembly out twice but never hooked it up with the upper off. after all the research i have done on this i would say its time to replace it and move up to the mpi kit. ok i will try that sometime this week. i never have seen an pooling but that doesnt rule it out.

kalamykid :

It can be leaking and the air moving through the intake is pulling the fuel into the cylinders.

Customer:

ok i will try that. thanx

kalamykid and other Chevy Specialists are ready to help you