How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15201
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

2005 chevy tahoe: rear door..power window inop..gm..bcm

Customer Question

2005 chevy tahoe passenger rear door , power locks and power window inop from rear door and drivers master switch. used gm tech 2   and looked at bcm inputs . inputs changed from active to inactive when using the master switch , no input change from rear door . im thinking i may need to replace the door harness , since the bcm responded to the other switches . and there is no power or control of locks or window on just the rear drivers door
Submitted: 8 years ago.
Category: Chevy
Expert:  goodwrench9124 replied 8 years ago.
Hello, and welcome to JA!!! just so I make sure I understand you correctly, both rear door power door locks and windows are inop even with the master driver door switches?
Customer: replied 8 years ago.
no im sorry i think i said left and right its just the drivers side rear door . nothing on that door works but when i hooked up the tech 2 and was looking at the bcm inputs it was switching from inactive to active when i was using the master switch but no response from the drivers side rear door . im not sure but i was kind of ruling out the bcm because i was getting a response from master switch .
Customer: replied 8 years ago.

no im sorry i think i said left and right its just the drivers side rear door . nothing on that door works but when i hooked up the tech 2 and was looking at the bcm inputs it was switching from inactive to active when i was using the master switch but no response from the drivers side rear door . im not sure but i was kind of ruling out the bcm because i was getting a response from master switch .

 

i work at a gm dealer and using service info program from gm that we use it didnt really give me much of a trouble shooting guide it was for either locks or windows and none of my results really matched up hope you get this i just clicked back hope it sends again

Expert:  goodwrench9124 replied 8 years ago.
your are kinda thinking right here, but you are only seeing half the info. the fact the bcm is seeing the imput from the switch only tells us the switch is sending a signal to the bcm, we dont know yet if the bcm is performing the command to run the left rear door lock and window. using the tech 2 , can you work the rear window and locks?
Customer: replied 8 years ago.
it gets the input from one switch and not the other , is why i was thinking that , no i was unable to get it to work with the tech 2 . also test for power at the window motor with test light and with meter nothing . this was with everything pluged in
Customer: replied 8 years ago.

im not sure on what other test i can run besides maybe testing the wiring between the bcm and window motor and lock acutator for continuity , im at home now though i ran out of time to run more tests

Expert:  goodwrench9124 replied 8 years ago.
ok, we still havnt rule out the bcm at fault.what about connector C310, this is the pass thru connector to the left rear door. runs thru the B-pillar, ahve check for a connection problem at this connector?
Customer: replied 8 years ago.
no i didnt get time to ill have to check there in the morning , any other suggestions and a way to get ahold of you through this site , or a time your usaully on . i want to be able to give the good faith deposit just cant till friday . thanks for your helpso far electrical isnt my strong point .
Expert:  goodwrench9124 replied 8 years ago.

no proble, sounds like you are a felow tech that is struggling with this one. been there many times myself. if you dont see any real obivous with the connector, check for power and grounds at the connector c310. this will tell you if the problem is more towards the bcm. i will be on here tomorrow tonight. i will check your progress at noon. let me know what you find

 

 

 

 

 

Customer: replied 8 years ago.
k i will thanks again
Expert:  goodwrench9124 replied 8 years ago.
no problem anytime!!